LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

CompactRIO – Receives error when trying to reference FPGA VI and Host VI

Hi all.

I have used LabView for several years, but I’m a beginner with the LabView Real-time module and FPGA-module. I have a CompactRIO (NI cRIO-9002) unit and two NI 9233 AI modules. To get familiar with these units I wanted to start with the example for NI 9233 that comes with LabView. I followed the instructions on how to transfer the example to a new target and copied the files to a new project. I compiled and downloaded the VI for the FPGA, and it worked fine (Wow I just programmed an FPGA with LabView!:-) I then tried to download the code for the host and that was when my problem started. I right clicked the Open FPGA VI reference\Select VI and selected the FPGA VI in my project. I the pressed the run arrow, but when the program is being deployed I get the error “Failed to download…”

When I tried to download a simple test program without any reference to the FPGA it worked fine. I started deleting blocks in the VI to isolate the problem and ended up with just a Open FPGA reference and Close FPGA reference that failed to download.

What could that be?

 

If I run the Host VI on my laptop it works fine and receives the measurements from the FPGA.

 

Any help would be greatly appreciated.

 

Best regards,

Terje

0 Kudos
Message 1 of 3
(2,572 Views)

I just updated the software on the CompactRIO and now it seems to work fine.

0 Kudos
Message 2 of 3
(2,566 Views)

I have developed a simple VI that calculates the FFT of a real time signal acquired through DAQ. Now I want to program FPGA with this code. Since I am very new to Labview and related hardware(just started learning it a month ago) I dont know where to start from. The hardware I am using is NI PXI 1031, NI PXI 8106 (embedded controller), PXI 7833R reconfigurable I/O, PXI 6512 Industrial digital o/p

 

Plz help me out. 

0 Kudos
Message 3 of 3
(1,579 Views)