LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Compact FP Communication Performance

I am using Compact Fieldpoint to Run an RT application. One of the modules is a DO. The hardware responds very fast as my program turns these channels on or off. But when I monitor the same module via Datasocket from the GUI on tHe host pc. There is a 1/2 sec lag.... I am using thelookout protocol and the new ds vi. that comes with the rt pallett. any ideas ?
0 Kudos
Message 1 of 4
(1,582 Views)
Two possibilities are related to the processor loading on the cFP-20xx module. In FP-20xx and cFP-20xx modules, there are two programs that are running simultaneously; the LabVIEW Run Time engine and the IA Control environment. The IA Control Environment is responsible for the publishing of the data items via the lookout protocol. If the LabVIEW code is running at a higher than normal priority, it may not be allowing the IA Control Environment as much processing time as it requires to publish the data at more than 1/2 second intervals. Alternatively, in FieldPoint Explorer, you can right click on a network module (RT only) and choose Edit This Device. One of the parameters is called Pause (ms), this parameter allows you to put the IA Control Environment to sleep f
or the amount of time specificed by the Pause parameter. If your module is currently set to 500 ms, that may also be why you are only seeing updates after a half second.

Regards,
Aaron
0 Kudos
Message 2 of 4
(1,581 Views)

Hi. I am using a cFP 2100 too. There is an DIO module and I face the same problem. The TC120's response is also retarded. The same thing is for the AIO unit.

  There seem to be a 1/2min or more lag. However, when I monitor the system hardware, the LED blinks is fine. When reading in the values, this problems comes out. I need a highly accurate RT system. This is not very Real Time. Is there any way to solve?

 

Many Thanks!:womanhappy:

0 Kudos
Message 3 of 4
(1,432 Views)

Can you describe your setup in a little more detail?  What modules and how many channels?  Where are you seeing the lag -- on the Host?  When targeted, or with executable downloaded and communicating with the host?  How are you communicating with the host?

Thanks,

-Khalid

0 Kudos
Message 4 of 4
(1,422 Views)