LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Charakters like ř or č are not displayed on dialog box and on front panel

Solved!
Go to solution

Please can somebody help with displaing sign like č and ř on dialog box or front panel. I wrote text to string constant (dialog box) or directly on front panel as like label. I tryed to use some tools from Unicode library but it doesn´t work.

Thanks you for help.

0 Kudos
Message 1 of 6
(309 Views)

In labview.ini, if you have

UseUnicode="True"

you should be able to just paste the characters in.

"If you weren't supposed to push it, it wouldn't be a button."
Message 2 of 6
(247 Views)

I push UseUnicode="True" to file labview.ini and still nothing. 

UseUnicodeTrue.png

0 Kudos
Message 3 of 6
(228 Views)

Try this.

Note that the "Interpret As Unicode" is like Font and Color properties in that it is changeable from character to character.  When setting it, it affects whatever characters are currently selected.

"If you weren't supposed to push it, it wouldn't be a button."
0 Kudos
Message 4 of 6
(183 Views)

This characters will most likely display correctly in LV 2024 Q1 or prior to LV 2022. 

 

Bojan

0 Kudos
Message 5 of 6
(159 Views)
Solution
Accepted by topic author Misha4200

I found solution. So first of all I have to export VI String from front panel. So I was click on tools->Advance->Export Strings... . After that Labview generate text file of front panel strings (labels, captions). In this text file I rewrite unrecognized signs and save and close this txt file. After that I import this text file back in to Labview (click on Tools->Advance->Import String...). 

 

PS.: If you want edit label of controls and indicators you should edit caption not labels. 

0 Kudos
Message 6 of 6
(120 Views)