LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot locate Network shared variables in PSP browsing

Hi, 

 

I created network shared variables on one PC and deployed the library. Then on a separate PC (which is on the same network host), I created a new project and tired to bind new variables to these ones using aliasing. However when I tired to browse with PSP, I could locate the first PC but it did not show any network shared variables. Kindly suggest me what can I try to solve it.

 

Best Regards,

 

Shah

0 Kudos
Message 1 of 8
(2,817 Views)

Hello svds

 

Have you tried to use the Distributed System Manager in order to see all the variables in the network?

 

http://www.ni.com/download/ni-distributed-system-manager-2015/5471/en/

 

Regards

0 Kudos
Message 2 of 8
(2,768 Views)

Hi,

 

I monitored them using distributed system manager, however, the variables created on computer show up under Network Items->Computer name. But they do not show up when I try to view them through other computer using Distributed system manager.

 

Regards,

 

Shah

0 Kudos
Message 3 of 8
(2,762 Views)

Hi, you may need to configure your firewall on the machine hosting the variables.  see here: http://www.ni.com/white-paper/12402/en/  

It is worth disabling your firewall briefly, just to see if the firewall is the issue.

0 Kudos
Message 4 of 8
(2,759 Views)

Hi Michael,

 

Disabling the firewall worked with following observations:

1- I only need to disable firewall on the PC that publishes the variables. The one receiving it can have the firewall ON.

2- The method recommended here http://www.ni.com/white-paper/12402/en/  , did not work. I created the required file and changed the number of ports to search from 100 to 1000. The issue persists. 

 

I guess I need to look more into accessing labview through Firewall. Thanks a lot for your advice! 

 

Regards,

 

Shah

0 Kudos
Message 5 of 8
(2,747 Views)

I looked back and found i emailed NI, here you go : Shared variables require port 2343 to be opened for UDP and TCP as can be found
here:
http://zone.ni.com/reference/en-XX/help/371361H-01/lvhowto/psp_firewall/

 

I have asked NI to update the document.  And you are right, these settings need to be added to the machine serving the variables.

I hope that works for you.  Michael.

0 Kudos
Message 6 of 8
(2,743 Views)

Hi Michael,

 

Sorry for delayed response. It turned out that I ONLY had to put exceptions for tagsrv.exe and lkads.exe in my windows firewall. I did not had to change any TCP ports etc, I only had to enter new rules for these two files in the inbound rules of firewall. Thanks for your support. 

 

Regards,

Shah

Message 7 of 8
(2,723 Views)

Same problem and this was helpful, solved my problem.

Thank you

Davide Vittorio G. - TLGB S.R.L.
Italian SW Developer
0 Kudos
Message 8 of 8
(2,098 Views)