LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot connect to PXI-8196 RT target in MAX

Solved!
Go to solution

I'm trying to set up the inital connection to my RT target (it was a used model, configured by an NI engineer to run LabVIEW RT before it arrived at our lab), but haven't had much success.  I've connected the RT target, a PXI 8196, directly to my host Windows computer using an Ethernet cable, and manually set an IP address for that connection in Windows Network & Sharing Center.  When I try to connect to the RT target in NI-MAX, I do the following: Create New --> Remote Device (not on the local subnet) --> Enter the IP address I've manually specified.  When I hit "Finish," however, I receive the following error message: "Unable to initialize connection to remote target(s)."

 

I've disabled Windows Firewall on this Ethernet port, and also downloaded and re-installed PXI Platform Services.  Is there a step I'm missing, or anyone have suggestions of what else to try?

 

I'm using NI MAX v5.6, running Windows 8 on the host computer, and the embedded computer is a PXI-8196.  Many thanks in advance!

0 Kudos
Message 1 of 5
(2,677 Views)

Can you verify the IP address that the controller is booting up to by connecting a monitor?  The Reset IP dip switch could be turned on, in which case if it fails to connect to a DHCP server, it will boot to a 169.254.xxx.xxx address.

Have you tried using a crossover ethernet cable?  Some NICs don't automatically support direct connections with a normal ethernet cable.

What are the IP settings of your computer (IP and subnet)?

Applications Engineer
National Instruments
0 Kudos
Message 2 of 5
(2,640 Views)

SkyWalka, thank you for the reply.

 

I just hooked up a monitor, and the controller is booting to a 169.254.xxx.xxx address --- although not the one I specified in Network & Sharing Center when I changed the IPv4 properties to manually set the IP address.  Regardless, if I enter the IP address displayed by my RT target into Network & Sharing Center and into NI MAX for creating a new remote device, I'm still getting the same error.  The subnet of my host computer is 255.255.0.0.

 

What are the implications of the Reset IP dip switch being turned on?  How would I change that?

 

The PXI 8196 manual says that the Ethernet controller can perform an automatic crossover, so there is no need for crossover cables.

 

Thanks,


Tracy

0 Kudos
Message 3 of 5
(2,631 Views)
Solution
Accepted by topic author tm473

I just went through this with a different PXI controller.  You absolutely do want the PXI to come up with a Link-Local 169.254.x.x address, as this will allow you to force MAX to connect to it.

 

Start by setting your PXI controller up with a monitor, so you can see what is going on, and what address it is using, and a keyboard, in case you need to get into the controller's BIOS.

 

On your PC, connect an Ethernet cable from the NIC you are using for PXI communication to the PXI.

 

Assuming that your PXI has a 169.254.x.x address, set your NIC to also have a similar (but different!) address, using a subnet mask of 255.255.0.0 (so the 169.254 parts have to match, but the other two numbers can be anything).

 

Now open MAX.  Click on Remote Systems.  I'm assuming you show nothing there, and the right pane is empty.  Over the right pane, click "Create New ..." and select "Remote Device (not on the local subnet)".  Yes, it is on the local subnet, but never mind.  When it prompts you for the IP, put in the IP that the PXI's monitor shows as the PXI's IP.  It should find the controller almost instantly.

 

What I'd do next is to set up the IP you really want to use.  In my case, I'm using 10.0.x.x addresses for both my NICs that "talk to" PXI's and my PXI's.  While MAX is talking to your PXI, you can set the IP, then reboot the PXI -- you should see it come up with the new IP you specified.  Of course, if you changed its IP to a 10.0.x.x address, you'll have to change your NIC to also use an address in that range.  Once both have been reset, MAX should be able to find the PXI under Remote Systems.

 

Now all you have to do is Add/Remove Software and you should be good-to-go.

 

Bob Schor

Message 4 of 5
(2,610 Views)

Worked like a charm!  Thanks so much, Bob.

0 Kudos
Message 5 of 5
(2,571 Views)