LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't create LabView VIs from Visual Assistant

Create LabVIEW VI feature in Visual Assistant is not working smoothly.

 

When I try to create a LabView VI two prompts show up for 2 different files; "Find the VI Name "nirio_FindDevices.vi" and "Find the Control Name "_nirio_device_attributes.ctl". (Screenshots included).

 

After cancelling both prompts, I am taken into LabView where the block diagram is locked behind a password. I have tried my passwords and none can unlock it.

 

Both versions of LabView and Vision Assistant are 2020 SP1.

My machine is a Ryzen 4800H 32GB RAM with Windows 10

 

The VI I'm trying to create is just a simple Image Display VI

 

 

I have also tried to repair both software and re-installing but the problem persists.

 

Can anyone please help me?

 

Download All
0 Kudos
Message 1 of 6
(1,211 Views)

I am having the exact same issues....have uninstalled/reinstalled the 2020 SP1 versions (LabVIEW and Vision Development Module).

Installed 2020 versions and getting same error now??

0 Kudos
Message 2 of 6
(1,183 Views)

Install the NI RIO driver to fix the issue.

0 Kudos
Message 3 of 6
(1,150 Views)

Thanks, but this doesn't seem to have solved it. I installed the NI RIO 14.5 (Legacy) drivers...

I have been using Vision Assistant & LabVIEW for many years and never had these problems, just wondering if its an issue with 2020 SP1 versions.

0 Kudos
Message 4 of 6
(1,118 Views)

NI CompactRIO install has solved the issue....

Message 5 of 6
(1,111 Views)

Compact RIO drivers installation sorted out the problem for me. But no idea what is the relationship with Compact RIO with Vision Assistant code generation. 

Thanks for the suggestion. 

Message 6 of 6
(104 Views)