LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

[Bug] Default control style ignored in classes

Taking time out from LVOOP before I break something I may regret to report a bit of a nuisance.  What is cheesing me off today is that my default control style (system) is being brazenly ignored by LV inside VIs which are owned by a class.  All controls/indicators created are modern.  argh.  Could be worse, it could be making everything silver.

 

1. set default style to system or silver or classic

2. in a vi outside of a class, drop a constant on the BD and create indicator -> should match the style set in 1

3. in a vi inside of a class drop a constant on the BD and create indicator -> modern style Smiley Mad

 

Also, the scripting VIs for methods and accessors ignore the preferences for default label position.  At least that one I can fix myself.

0 Kudos
Message 1 of 4
(1,771 Views)

Hi Darin,

 

Thank you for your feedback. I tried creating indicators inside of a VI in a class and it observed my default control style in LabVIEW 2013. Which version of LabVIEW are you running?

 

Regards,

Matthew B.
Test Software Offering Manager
NI
0 Kudos
Message 2 of 4
(1,748 Views)

Glad I check the mobile version of the site once in a while, I had missed your reply.  I see this in LV13 (including very very recent versions of LV13).

 

I think it involves the static or dynamic dispatch template VIs.  If you simply create a new VI in the class it behaves normally.

0 Kudos
Message 3 of 4
(1,700 Views)

It's not a bug. It is the defined behavior of templates. Changing it is a feature request that, although I think it would be nice to change, is not currently prioritized. You can edit the file

LabVIEW 2013\resource\Framework\Providers\LVClassLibrary\CLSUIP_MemberTemplate.vit

to change the template. Applies to any of the other templates in that directory.

0 Kudos
Message 4 of 4
(1,679 Views)