Showing results for 
Search instead for 
Did you mean: 

Arduino vis'a Read problem

Go to solution

Hi! I am writeing a program which will write "a" to arduino to make it start some proces and then write "b" to make arduino send all the data. So as far as it is to make arduino do something it is good, but when i order arduino to send me data ( trough print() function. I get about 20s of silence from laview and error about timeout. I can see on arduino it is working and when i work on ardunio programing software i can get what i want and there is no problem. But Labview can;t see the answer. I am attaching whole project ... Plis help me guys!

PS: Program on arduino is working good. Arduino listens to the orders...

0 Kudos
Message 1 of 5

Are you using a termination character at the end of the data received or how do you know. The default VISA timeout is something like 20s so you're probably not getting either the number of bytes you requested or there is no termination character (if you have one configured).


You can either use a termination character at the end of each line or at the end of your data or you can use the 'number of bytes at port' property of the VISA connection to see how many bytes are available and then read that many.

LabVIEW Champion, CLA, CLED, CTD
0 Kudos
Message 2 of 5

The program provide me with 180 pairs of data each 3 numbers separetaed with "/"between pairs and "." betwen elements of pair. So i set it to read 1440 bits ... since it is 8*180    so i get times 180 ... Then i separate each from rest and then separate thouse xxx parts from each other ...


0 Kudos
Message 3 of 5

If you open file i atached there is subvi ... In it there is all about reading i even tried to finde right timeing between arduino and labview by makeing it w8 but i tried many amounts of times and non did work. In this file there is everything about reading ... as i made it ... There is one subvi of my creation it just take care of separating data so it is not important to the downloading data proces...

0 Kudos
Message 4 of 5
Accepted by Kertul

I found it ! IT worked befoure but i used a vi to separate string output and i used "." as maching symbol. So i found out that it can;t be "." progra mdoesn't see it at all 😄 Thx for help...

0 Kudos
Message 5 of 5