Showing results for 
Search instead for 
Did you mean: 

Access Error: 401 -- Unauthorized

Go to solution

I'm trying to access a snapshot of a remote application through my company network. I created the web page using the Web Publishing Tool and added the "WebServer.Enabled=True" line in the initialization file of the application. I also adjusted the "niwebserver.conf" to match the DocumentRoot and Directory Index. The problem is that even if I try to access it in the local machine through the browser I get the "Error 401" message (any browser: Edge, Chrome, Internet Explorer). I have similar applications running in other machines without any issue. I don't know what to do to solve this, already tried to republish, redo the conf file, unblock application in the firewall... searching in the Community I couldn't find anything that could help me to solve it.


PS: I wasn't able to add the "niwebserver.conf" here because it triggered content blocker. Not even pasting the text here...

0 Kudos
Message 1 of 4

Do you know what error 401 is?  Basically it's an authorization error - e.g., wrong password or something.

(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 2 of 4

An update on this: I reseted all options to default in the Web Server configuration, under Tools>>Options>>Web Server. After that I recompiled the application and the error 401 doesn't appear anymore, now I got an error 404: not found. The DocumentRoot is pointing to the right place and the web server is enabled to deploy.


I have a different application running in the same PC that I can access without any issue. Then I tried to copy the config files from this application and just adjust the paths but I continue to have the error 404.


Access Error 404.png

0 Kudos
Message 3 of 4
Accepted by topic author FBro

The problem was solved with the help from the NI Support. The only solution was uninstall all NI software from the PC and reinstall the application using by building an installer.

0 Kudos
Message 4 of 4