LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview Lego Mindstorms 2015 incompatable with Mac OS X El Capitan?

I am unable to install the Lego Mindstorm module for Labview 2015. I don't know if this is a specific issue to me or if it is just not supported on El Capitan across the board. I was able to get the 2014 version to run the installation wizard up until it recognized that I have Labview 2015 and not 2014 so I don't know why the 2015 version won't work on my mac. Help would be greatly appreciated.

0 Kudos
Message 1 of 9
(8,527 Views)

Hi AAkelly,

 

Could you provide more information about what actually occurs when you attempt to run the installation? Do you get any error? Does the wizard launch?

 

Additionally, could you make sure that you are using the installer from the following URL:

 

http://www.ni.com/download/labview-nxt-module-2015/5419/en/

 

Regards,


Kyle S.
Applications Engineer
National Instruments
ni.com/support

0 Kudos
Message 2 of 9
(8,506 Views)

As soon as the install wizard launches it pops up a window that states, "This product is not supported on the version of Mac OS X on this disk."

0 Kudos
Message 3 of 9
(8,408 Views)

Hi Aakelly,

 

Unfortunately, it looks like Mac OS X 10.11 is not supported in LabVIEW 2015, and as a result the module is also not supported. Mac OS X 10.9 and 10.10 are supported for LabVIEW 2015.

 

A potential workaround would be for you to downgrade your Operating System to a supported version and then attempt to install LabVIEW 2015 and the corresponding module.

 

Please refer to the LabVIEW 2015 for Mac OS X README for Operating System compatibility information: http://www.ni.com/pdf/manuals/374717c.html

 

Regards,

 

Kyle S.
Applications Engineer
National Instruments
ni.com/support

0 Kudos
Message 4 of 9
(8,402 Views)
Labview 2015 is supported on 10.11. I have it and have been using it for several weeks.
0 Kudos
Message 5 of 9
(8,393 Views)

Hi Aakelly,

 

According to the README for LabVIEW 2015 it is not officially supported in 10.11 and that is the reason you are seeing the message from the module installer. The fact that LabVIEW 2015 installed and that you can use it is not an indication that LabVIEW 2015 is officially supported for that Operating System.

 

Regards,

 

Kyle S.
Applications Engineer
National Instruments
ni.com/support

0 Kudos
Message 6 of 9
(8,389 Views)

Been able to run the EV3 and NXT on my late 2015 iMac with 11.11.4 beta.

 

Had to install a fresh Sylverlight and use the installer on the Lego website.

0 Kudos
Message 7 of 9
(8,049 Views)

Would you please explain your procedure a little bit in detail? It will really help me a lot...

0 Kudos
Message 8 of 9
(7,504 Views)

Hi All,

 

The LabVIEW 2015 Module for LEGO(R) MINDSTORMS(R) is not officially supported on Mac OS X El Capitan. To reflect this, the original installer for this version would display an incompatibility error and force you to close the installer:

 

LMLM1500Installer.png

 

However, we recently updated the installer to allow you to continue beyond this warning and install at your own risk despite the lack of official suport:

 

LMLM1501Installer.png

 

Just to reiterate, LMLM 2015 is still not offiically supported on El Capitan, but feel free to download the latest installer from here:

 

http://www.ni.com/download/labview-nxt-module-2015/5419/en/

 

Thanks.

- Aaron

0 Kudos
Message 9 of 9
(7,468 Views)