LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Did you mean: 

Help: Problem with parallel execution


I've written a VI for NXT, using the NXT Toolkit, which contains too while loops, which are intended to run in parallel.
The first loop drives and steers motors B and C depending on ultrasonic sensor readings and
the second loop does some collision detection using the touch sensor.

The first loop works fine, but the second one seems to be execute never or at all only very

I've already done the following this to fix this with NO success:
  • Give loop execution priorities, by using NXT delays in the loop
  • Move each loop into a separate subVI and built a main VI, which only
    calls both subVIs.
Both methods yielded no success. How can I accomplish parallel execution of
both loops ?  See attached VI for details.

Thank you very much !!

Message Edited by markus_71 on 01-06-2007 07:07 AM

0 Kudos
Message 1 of 6
are these while loops on the same level or is one while executed after the other?

and an important question
:is the endcondition of both while loops the same?

or send in your block with sub blocks so we can look at them.

greetings from the Netherlands
0 Kudos
Message 2 of 6
Hello Albert,

thanks for your response !

Yes the loops are on the same level and have the same exit condition (in this case
endless loops). Ich also tried different end conditions with no success.

Sorry I missed to attach the VI ... here it comes.


Message Edited by markus_71 on 01-06-2007 10:01 AM

Message Edited by markus_71 on 01-06-2007 10:02 AM

0 Kudos
Message 3 of 6
Both loops are executed, no problem
I try to load my nxt toolkit under lv8.2
at this moment in 7.1.1

see you
greetings from the Netherlands
0 Kudos
Message 4 of 6
Hello Albert,

yes I'm using LV8.2.

I implemented the same program in NXT-G (Lego out-of-the box software), there it works also fine !

I'll reload the LV program later and do some tests, at the moment I have 7.1.1 not installed here.


P.S.: By the way ... I also work for Philips (Medical Systems Böblingen) and we had some mail exchange
some years ago, reagarding a decision about LV/TestStand as our new testplatform 😉 🙂
It took just a few posts to recognize you ... the world is small !

0 Kudos
Message 5 of 6
Hello again,

after playing around with some other VIs I reloaded the VI mentioned above and
it worked ... I don't know what the initial problem was ...
So far  - all OK, thanks for your help, Albert !

Best regards,

0 Kudos
Message 6 of 6