LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Enter Bluetooth Passkey

The 2.0 Toolkit works great, exept I can't use the toolkit wirelessly.  Everything works fine with USB, both downloading programs and the Direct Commands.


I'm using a. . .
-Lenovo Laptop
-32-Bit Windows Vista Home Premium
-"ThinkPad Bluetooth 2.1 with Enhanced Data Rate" and "Microsoft Blutooth Enumerator"
-LabVIEW 8.5 with "LabVIEW Toolkit for LEGO® MINDSTORMS® NXT 2.0"
-NXT with firmware version 1.26

When I launch the "NXT Terminal" and click "Find NXT" and then "Scan" it quickly locates my NXT, lists the correct name, connection type as "Bluetooth", and status as "Available".

When I click Connect it prompts me for the passkey on the computer, I keep the default "1234" and click okay.  After a couple minutes of waiting, during which the NXT screen never changes, the following dialog box appears:

Problem:
NXT Bluetooth passkey confirmation failed.

Suggestions:
- Retry the current operation.

- Enter the Passkey on the NXT device.

- Ensure the Passkey entered on the NXT device is correct.

I retried several times.  Then I tried adding the NXT to the windows bluetooth devices and it was able to pair with windows just fine, I was prompted to enter the passkey on the NXT, but when I returned to the NXT terminal I still had the same result, the NXT never asked me for a passkey.

 

 

I also had no luck using the direct commands with bluetooth, it just waits a while and then the message pops up saying "Error: Could not connect to: [NXT Name]"

 

Does anyone have some suggestions?  Is there any other information I can give the might help?  Thank you so much, I'd love to get this working!

0 Kudos
Message 1 of 7
(12,243 Views)

Maybe you should try to connect to the computer from the NXT first. I know there's a bluetooth menu on the NXT. Maybe the password got changed too. Maybe look at the NXT-G instructions for connecting with bluetooth and that will give you some tips.

Other than that, I don't have much experience with Bluetooth, so sorry.

0 Kudos
Message 2 of 7
(12,205 Views)
I had the same problem and i resolve it installing the 1.25 firmware, look inside the directory where is installing the toolkit 2.0 for a folder named firmware. update the firmware of your lego with that file
0 Kudos
Message 3 of 7
(12,177 Views)

I can connect the NXT bluetooth link to the computer first, but that makes it worse, then I can't locate it at all.

 

I navigated to C:\Program Files\National Instruments\LabVIEW 8.5\vi.lib\addons\NXTToolkit\Firmware, but the only firmware file was "LEGO MINDSTORMS NXT Firmware V1.26.rfw", which is what I currently am using.  Does anyone know where I can get the 1.25 firmware that Zotz mentioned?  Could someone attach the file to their post?

 

Thanks!

0 Kudos
Message 4 of 7
(12,121 Views)
Srry the firmware is the 1.26 not 1.25. you can update it with labview
0 Kudos
Message 5 of 7
(12,110 Views)

exact same problem here

 

bluetoothconnection some time asks for a passkey some times not.  I'm using vista, with dell 370 Bluetooth,  on my vostro it works semi fine on a latitude e6500 I can scan for the nxt but not connect using the connect button.  Does anyone have a solution for this problem?

 

pieter

 

 

 

0 Kudos
Message 6 of 7
(11,255 Views)

Can you show the detail steps or give a link?

0 Kudos
Message 7 of 7
(3,481 Views)