Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

"Error caused by remote command" in Keysight 34461A.

Solved!
Go to solution

Now I want to control Keysight 34461A's multi-meter via SCPI. When I run "SYSTem.REMote" command in PC side, the meter screen shows "Error caused by remote command", later the meter can be controlled by PC's SCPI commands and no error message shown again. Every time I run code to set remote mode, the error message will show on the multimeter screen. I don't know what caused this displayed message in multi-meter. Can anyone know the root cause? Thanks.

0 Kudos
Message 1 of 9
(2,952 Views)
Solution
Accepted by topic author jimmy0415

Hi

With scpi you can ask for the error code if not visible in the screen of the meter.

But I also found an old reply from Minions (thanks for that)

https://forums.ni.com/t5/Instrument-Control-GPIB-Serial/USB-devices-Go-to-Local-Function/td-p/769936

the interesting part is copied below.

 

Try using the:

:SYST:COMM:ENAB OFF,USB

command for turning off the USB control (local mode) and:

:SYST:COMM:ENAB ON,USB

command for turning on the USB control (remote operation) for the Agilent 34410A meter.

 

This is not common for all other USB devices. Similar, but not always the same. I have found this for another instrument:

:COMM:REM 0

greetings from the Netherlands
Message 2 of 9
(2,935 Views)

Very grateful for your reply,

I have tried this method, but the problem still occurs.

Maybe need further investigate. I attach a snapshot. Thank you for your warmly help again.

168d2d64bdd2614022545fe3fb6caeb.jpg

 

0 Kudos
Message 3 of 9
(2,915 Views)

From what I see in the upper right corner is that the machine is in remote mode.

So the problem is maybe in the last part of what you are sending.

Can you show the program you are using?

greetings from the Netherlands
0 Kudos
Message 4 of 9
(2,886 Views)

Hi Albert,

     Actually, by debugging and checking user manual, I finally find your solution is correct. Keysight meter can't use "SYSTem:LOCal" and  "SYSTem:REMote" to set local/remote mode (Fluke/keithley/tek can use these SCPI command), it can only use "SYSTem:COMMunicate:ENABle OFF, USB" and "SYSTem:COMMunicate:ENABle ON, USB" to set local/remote mode.

   The reason for I still meeting error message for second time is I only input "SYSTem:COMMunicate:ENABle ON/OFF" and miss " ,USB" word. That's my fault.

   By the way, when we meet error in Keysight meter's screen, we can run "SYSTem:ERRor?" in code to get detailed error message.

   Thank you for your warmly help. 

0 Kudos
Message 5 of 9
(2,854 Views)

Glad I could help.

greetings from the Netherlands
0 Kudos
Message 6 of 9
(2,844 Views)

Buenas tardes tengo un error un contador c cual sería la solución 

Screenshot_2023-09-03-05-31-00-09_99c04817c0de5652397fc8b56c3b3817.jpg

0 Kudos
Message 7 of 9
(2,113 Views)

Cuál fue su solución de la falla keysight 53230a el uso Error caused by remote command errores

0 Kudos
Message 8 of 9
(2,110 Views)

That error mentions that you sent a message that the equipment did not understand.  Please post the exact command string sent to the 53230A Keysight instrument for us to further assist you.

Help the Community (and future reviewers) by marking posts as follows:
If it helped - KUDOS
If it answers the issue - SOLUTION
0 Kudos
Message 9 of 9
(2,002 Views)