Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Yokogawa gs200 not responding to any queary (GPIB)

Go to solution

Hi all, I am trying to program a Yokogawa gs200 and NI MAX recognizes it, but any queary or read command is returned by a timeout error and the red error light is always on on the instrument after the first error is ecountered. Does anyone know how to solve this? Thank you all.

0 Kudos
Message 1 of 7

Basic stuff that literally every Topic requesting help with GPIB/VISA fail to do,

  • Post some snippets or VIs that show what you are facing - unfortunately rarely someone can read your mind or peep into your computer
  • Post the GPIB settings you're using
  • Is there any setting on the instrument to put into remote control mode?
  • GPIB address configured properly on the instrument?
  • 90% time, the issue is with your choice of termination character that makes the instrument think that the message is still not complete (analogy - imagine when someone talks over the radio they don't end with 'over' you will still wait thinking that the other person has not completed talking)
  • To make things easy, always post the programmer's manual of the instrument you're using (we don't know all instrument details magically)
Soliton Technologies

New to the forum? Please read community guidelines and how to ask smart questions

Only two ways to appreciate someone who spent their free time to reply/answer your question - give them Kudos or mark their reply as the answer/solution.

Finding it hard to source NI hardware? Try NI Trading Post
0 Kudos
Message 2 of 7



Did you use the driver package for this instrument ?

Did you tried the example VI ?



0 Kudos
Message 3 of 7

ok so it turns out that the GPIB connection was not working properly, i switched to USB and now the NI MAX detects the device and lets me communicate with it through the VISA terminal. The problem now however is that if i try to communicate with it through any labview program (including the test driver given by NI) it gives back a timeout error and nothing happens. This is an issue that shows up only if i interact via Labview programming, while direct communication works (i even started a couple sweeps just to check and they are perfect). I don't think it's a driver issue since the device is visible both in dev manager (as USB TMD) and on NI MAX. Do you have any idea?

0 Kudos
Message 4 of 7
Accepted by topic author Alfred96



Strange that GPIB is not working. I think you should why it is not working.


If you can communicate with the instrument with MAX you can also communicate  to it with LabVIEW (it is the same) but not both at the same time.

Close the MAX communication and try the LabVIEW program.



0 Kudos
Message 5 of 7

Thanks a lot, i think this was the issue. Today i just rebooted everything and both NI MAX and the labview script were now working. I think i was trying to access the instrument with the script while the VISA control from NI MAX was still open. Thanks again!

0 Kudos
Message 6 of 7

Glad that it works now !!


btw. Great choice of instrument !! 



0 Kudos
Message 7 of 7