Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Reason for GPIB delayed answers or unanswered


Hi everyone!

Thsi is te situation, some days ago I was looking for a way to know the commands to remote control an instrument for EMC it is a UCS (Ultra compact simulator), I finally found the commands but they don´t work on the correct UCS. The commands are for the UCS500M but works on the UCS500N. For example, I send EC;]\n to check the connection of the interface and I sometimes receive the identification of the device (UCS500N) but some other times I don´t have an unswer until I send one or two commands more. I´ve tried this also with the UCS500M but never had an answer. I have tried both Visa Test Panel and a VI using the visa subvi´s and observed the same bahaviour.

Does anyone have an idea of what is happening?


0 Kudos
Message 1 of 9

Could you supply some actual code so we can see the exact string you are sending? My thought is that you are not ending your command properly.  You are probably sending "\n" in the normal display when it should be in the \ Codes display.  \n represents an End Of Line character when in \ Codes display.

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 2 of 9

Here´s the actual code I´m using.

PD: I´m also usiing the VISA from NI max.

0 Kudos
Message 3 of 9

Now I´m receiving answer from the instrument but it is only after 2 or 3 times of sending the same command even with the correct termination byte. My thought is that the buffer is saving "trash" or kind of, I´ve tried clearing it after each query but haven´t a good result. This is the actual VI I´m using.


Any advise about that?

Thanks. Cheers.

0 Kudos
Message 4 of 9

Hello JEmmanuelH,


Thank you for using the National Instruments Forums. Regarding the situation, could you please share with us the documents where you find the commands for your devices?

These documents could help us all to understand more about these devices and try to help you with this.

I will be waiting for your answers.


Best regards!

Edgar Rosales
Ingeniería de Aplicaciones
National Instruments
0 Kudos
Message 5 of 9

Hi, first of all thank you for your time.

Attached below there is the Remote manual of my instrument, in addition I´ve attached the VI that I´ve used to deal with the problem described previously, just in case or if there is any recommendation. Up to this point the instrument responds at the firtst time of sending the identification command.

I´d thank any comment. Thanks for everything and sorry for the english.

Best regards.


0 Kudos
Message 6 of 9

Actually, section 1.2 of the manual points out the information that you have omitted after your command.  You are missing the transmission of the checksum and the terminating <LF> that are to follow the command.

Help the Community (and future reviewers) by marking posts as follows:
If it helped - KUDOS
If it answers the issue - SOLUTION
0 Kudos
Message 7 of 9

You should be transmitting:


with the \n being the single 0xA value.  Right now it appears that you are only sending the checksum value and not the command or the <LF>.


Help the Community (and future reviewers) by marking posts as follows:
If it helped - KUDOS
If it answers the issue - SOLUTION
0 Kudos
Message 8 of 9

Thanks for your reply.

How can I check it? I´ve checked the output array and the "Final String" indicator and both them show all the characters that are supposed to be sent including the linefeed.

0 Kudos
Message 9 of 9