Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

PCI 6509

Hello NI Community,

I have a NI's 6509 PCI card, which is being used to monitor/Control the test systems.

There is a LabVIEW utility that is being designed to achieve the above the purpose.

I had to format the PC in which this was installed due to some reasons and after completing the new installation of Windows XP OS,installing the NI-DAQmx 14.5 and the LabVIEW utility, i expected to run every thing as usual. However, the LabVIEW utility is getting crashed when tried to run with the error "

Error 1 occurred at Flush Queue in EMS1722_Test_Screen.vi->EMS1722_Main_Screen.vi->EMS1722_User_Authentication.vi

Possible reason(s):

LabVIEW: An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.".

 

I also tried installing NI-DAQmx 9.8 but result was same.

 

Anu suggestion on this would be helpful.

Thank you.

0 Kudos
Message 1 of 3
(1,262 Views)

Error 1 suggests a problem with an input to the Flush Queue function, which usually is related to the Queue reference being null or already destroyed.

 

I am unsure what the VIs EMS1722_Test_Screen.vi->EMS1722_Main_Screen.vi->EMS1722_User_Authentication.vi are, or how they were developed. If you have access to said source code, I recommend using the debugging tools to understand where the software is not getting the data it is expecting.

 

All the best,

0 Kudos
Message 2 of 3
(1,186 Views)

Hello Oscar,
Thank you for your response..


The issue was incorrect device name..
Since I had a couple of NI devices connected to the system, The device for each of the device was not as per the software requirement.

Once the devices were renamed the error was resolved.

 

Thank you again. 🙂

0 Kudos
Message 3 of 3
(1,176 Views)