Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Monitoring a Watlow F4 Controller

Solved!
Go to solution

Hey Everyone,

 

I have an ESPEC humidity chamber that uses a Watlow F4 controller.  I am using this to run environmental tests on a device.  Ideally I want to monitor the conditions inside the chamber and my device in the same VI.  So far I have been having trouble communicating with the chamber using labview.  It is using a serial port on the chamber and a serial to USB converter on the PC side.  I have created a small Vi that will just act as a chamber monitor for me.  I have attached the monitor VI below.   It doesn't sense the chamber at all and give me the set points or current conditions. Any help you guys can give would be greatly appreciated!

 

Regards,

PChemist

0 Kudos
Message 1 of 89
(19,438 Views)

Assuming it fails the init function, what error code do you get? Are you sure you are using the correct serial cable (null-modem or straight-through)? I don't have the driver. Where do you set the com port (baud, parity, etc.)?

0 Kudos
Message 2 of 89
(19,388 Views)

Thank you for helping me solve this.

 

I am using a USB to Serial converter ( http://www.newegg.com/Product/Product.aspx?Item=N82E16812339013 ) at the PC with a serial cable ( http://www.radioshack.com/product/index.jsp?productId=3964614 ) connecting from the converter to the chamber, I can't find what type it is.

 

The driver I am using is the 2009 version located at http://sine.ni.com/apps/utf8/niid_web_display.download_page?p_id_guid=E3B19B3E9722659CE034080020E748...

 

I am using Labview 2010 and have updated the NI-VISA Software to 5.0.3

 

The Watview software that comes with the controller communicates just fine.

 

In MAX the settings match with the controller, MAX indicates that "The device is working properly"

Settings listed in MAX are:

Baud Rate: 19200

Data bits: 8

Parity: None

Stop Bits: 1

Flow Control: None

 

When I use the VISA test panel I am able to Write the Command *IDN?\n to the controller without error. When I attempt to Read from the controller I get error BFFF0015.

 

When I run the ESPEC Monitor VI it generates an error at WLF4 Initialize.vi, error code BFFF000E.

 

Once again thank you for helping with this. I look forward to figuring this out and getting it working!

 

Regards,

PChemist

0 Kudos
Message 3 of 89
(19,374 Views)

Update:  I checked the Serial cable with my multimeter and it seems to be a straight through cable.

0 Kudos
Message 4 of 89
(19,370 Views)

Hi PChemist,

 

Have you tried communicating to the instrument through hyperterminal?

 

Thanks!

Chris T.
0 Kudos
Message 5 of 89
(19,368 Views)

I am not familiar with Hyperterminal. I was searching around and found this from another company who uses these contollers from the same thing. 

 

http://chamber.testequity.com/rs232.html

________

RS-232 Troubleshooting Tips for TestEquity Chambers

We receive many calls each week regarding RS-232 communication issues. There are several issues which must be addressed in order to communicate successfully with the chamber. With thousands of chambers in the field, we have never had a verified case of a bad serial interface in the controller. Below are several of the most common communication issues.

Are you using the correct cable?
The DB-9 connector is wired to accommodate a null-modem cable. A null-modem cable has pins 2 and 3 swapped on each end. You CANNOT use a straight through cable.

Is the baud rate set correctly?
All TestEquity chambers shipped since mid-2003 have the baud rate set at 9600. Older chambers have the baud rate set at 19200. The baud rate of the controller MUST match the baud rate in your communications program. The baud rate is changed in the controller's Go to Setup\Communications menu. You may require a password to enter the Setup menu. If so, call TestEquity to get the password.

Does your software communicate using the Modbus RTU protocol?
To communicate with the controller from a PC, you need to run software that uses the Modbus RTU protocol. You CANNOT use Hyperterminal.

Modbus Registers
Each controller function has a "register" number which can be read or written to (when applicable). These registers are listed Chapter Seven of the Series F4 User's Manual (pdf, 4M) .

Common Modbus Registers

  • The actual chamber temperature reading is Modbus register 100 (Input 1 Value).
  • The static temperature set point is Modbus register 300 (Set Point 1).
  • The temperature set point during a profile is Modbus register 4122 (Set Point 1, Current Profile Status).
  • The decimal points are implied. For example, 1005 is actually 100.5 and -230 is -23.0.
  • The Digital Output 1 (Event 1) function is Modbus register is 2000

__________

 

It appears that I can't use Hyperterminal for testing with the F4.

 

Since is says that I cannont use a straight through cable I wired up a quick cross over adapter ( http://digital.ni.com/public.nsf/websearch/1EE0DD8AF67922FA86256F720071DECF?opendocument&Submitted&&... ) and tried it.  I am getting error codes for function in MAX now.  Do you guys know if the F4 requires Handshaking? I didn't wire that into the adapter, just pins 2, 3 & 5.

0 Kudos
Message 6 of 89
(19,360 Views)

Hi Dennis I was wondering if you could help me 🙂 I am trying to complete a traffic control system using labVIEW. My scenario is "

Each road junction has the following functionality.

It is a crossroads of 2 main roads with traffic lights at the 4 corners with the timing set in the Control Engineer’s office. The lamps follow the standard sequence of Red, Red & Amber, Green, Amber and back to Red. Lights on the 2 roads must not be Green together but can all be Red for safety. Each junction can operate in 3 different ways dependent on the time of day.

 

I can get 1 set to work but am struggling to get a timing device set up. Any comments or examples would be greatly appreciated.

 

Liz

0 Kudos
Message 7 of 89
(19,356 Views)

Update:  The software that comes with the F4, Watview, can't communicate with the null-modem in place.  It has no communication problems with the straight through serial cable.

0 Kudos
Message 8 of 89
(19,353 Views)

Hi PChemist,

 

Looking at the F4 it seems like it communicates using the MODBUS protocol. Which would explain why you can't use *IDN? from VISA test panels.

 

Have a look at this Developer Zone article.

 

http://zone.ni.com/devzone/cda/tut/p/id/7675

 

Hope this helps!

Chris T.
0 Kudos
Message 9 of 89
(19,348 Views)

Thank you for the Modbus info.  The Vi's I am using are already using Modbus and can't communicate. Since I last posted I performed a loopback test using the Loopback.vi supplied by NI, it passed successfully.  This makes me think I am missing a setting somewhere, unfortunately the error codes I am getting are to generic to be helpful.  I have included the library I downloaded from NI (for the F4) for reference if anyone is interested. 

 

I really need to get this working, any guidance is much appreciated!

 

Regards,

PChemist

0 Kudos
Message 10 of 89
(19,323 Views)