Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Cannot find resource on Ubuntu 18.04

Hi everyone,

I installed NI - VISA driver on my Ubuntu 18.04 machine with version kernel of 5.4.0-99-generic in order to remotely control to the power supply of BK Precision model 9132B via USBTMC interface. However when I plug the instrument into my computer, I recognize that the VISA Interactive Control does not display the resource format of USB on the "Devices" scroll area when I hit the button "Refresh".

I also tried out on other Windows computer installed NI - VISA and the USB resource format for the instrument is detected perfectly.

The NI - VISA driver on for Linux I used is of version 2022Q1.


I have been googling but got no solution. Please help point me out something.


Thank you in advance.

0 Kudos
Message 1 of 3

[Updated] I have followed the workaround from, run the bash /usr/lib/x86_64-linux-gnu/ni-visa/usb/ and finished entering the instrument's feature in 4 digits hexadecimal code including the Vendor ID and the Product ID in order to grant the access permission to USB device, but still got nothing.

0 Kudos
Message 2 of 3

Hi, I have the exact same issue!


I'm trying to interface with a USB Test and Measurement device. In the end, I want to be able to interface with the device from my own C++ program in a Linux environment. However, I'm unable to list the USB device under Linux through the NI-VISA API, whereas on Windows it works perfectly fine. On Linux, the device does not show up in the provided control software such as the Visa Configuration and Visa Interactive Control software.


I tested with multiple USBTMC compliant devices, but no luck. However, when connecting a device, they are al listed in the /dev/ directory as 'usbtmc0' or 'usbtmc1'. So the device is properly recognized by the Linux kernel, but not by the VISA software. In comparison, on Windows, the USBTMC devices are perfectly recognized in the Interactive Control Software, and I've been able to communicate with the devices just fine.


What I've tried so far:

- Clean install of Ubuntu 20.04 LTS Kernel 5.15 on two separate devices (one through dual boot, another with only Ubuntu)

- Reinstall of the NI-VISA drivers.

- Changed to root mode

- Changed USB device permissions permanently


Also, I started out with Ubuntu 22.04 LTS, but I've been unable to get the software working. When I saw, it was not fully supported, I switched to Ubuntu 20.04.


Any suggestions?

Thanks in advance!


Kind regards,


Ulrik Van Hecke

0 Kudos
Message 3 of 3