Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Raspberry PI 4 LabVIEW Version Error

Solved!
Go to solution

I am trying to deploy a startup application with a web service and a G Web app through Linx to a raspberry pi 4. I am using LabVIEW 2021 SP1 Professional and I downloaded the Linx toolkit from VIPM for that version. I am able to open the Linx target configuration window in tools, connect to the device, and install software. It tells me that the configuration was successful. I can also see on the raspberry pi that it did create the directorys successfully. From a LabVIEW project, I get an error (whether I try to deploy the rtexe or just connect to the raspberry pi) that says that the version of LabVIEW on the raspberry pi doesn't match the version of labview that I am using. See attached. Is there a certain version of LabVIEW that I need to be using for this? I assumed Linx would install the appropriate run time per the version of LabVIEW that you were using. Do I have to use community edition? Do I need to use the latest version of LabVIEW? Or is there a way to install a different version of the run time than the default? Any help would be appreciated  as this is my first time trying to use Linx.

0 Kudos
Message 1 of 3
(1,369 Views)
Solution
Accepted by topic author cannoncontrols

You should not use the Linx toolkit fromVIPM for LabVIEW 2021 and later but the LabVIEW Hobbyist Toolkit!

 

And you should download the appropriate version for your LabVIEW from here: https://www.ni.com/en/support/downloads/tools-network/download.labview-hobbyist-toolkit.html

Rolf Kalbermatter
My Blog
0 Kudos
Message 2 of 3
(1,354 Views)

I completely missed that. Thank you for your help!

0 Kudos
Message 3 of 3
(1,345 Views)