Hardware Developers Community - NI sbRIO & SOM

cancel
Showing results for 
Search instead for 
Did you mean: 

C RIO Modules on sbRIO-96x7

Solved!
Go to solution

Hello developer community,

I have a problem here with which I no longer get on.

 

We have been using sbRIOs 9627 and 9607 in our measurement systems for years, which we operate on specially developed carrier boards.

Here is also intended by us to be able to plug C series modules. However, we have never used this so far, because our own special hardware was used on the other DIO lines, CAN, serial and so on.

 

The problem now is that no module is recognized (tested with 9205). When measuring at the pins I would have expected that e.g. when searching for the module at least on the CLK line once something twitches - but nothing happens.

 

Also selecting the module and creating an FPGA bitfile for it did not bring success.


We have already tested different PCBs and different sbrios and also recreated the Labview projects.

 

Does anyone have something similar working and can give me a hint?

I hope it's another one of those little things that are quite simple if you know them but search for hours beforehand...

 

Gretings

Tobias

0 Kudos
Message 1 of 5
(207 Views)

Hi Tobias,

 

Have C-Series modules ever worked with your custom carrier board before? If you could post the relavent part of your carrier schematic, I'd be happy to take a look at it. 

Nathan
NI Chief Hardware Engineer
0 Kudos
Message 2 of 5
(192 Views)

Hi Nathan,

 

the thing is - we never tried before, because there was no need for it until now.

On our other applications we use the 96 DIO lines, Ethernet on RMC and USB on RMC.

 

The schematic part is straight forward following the design guideline. You can have a look:

C_Series_Connection.PNGC_Series_Protect.PNG

5V is present, on other lines no signal. Connection to RMC connector is ok. sbRIOs we have on hand are 9607, 9627 and 9608. Tested with LabVIEW 2018 and 2020.

 

0 Kudos
Message 3 of 5
(168 Views)

Hi Nathan,

 

thank you very much for the support offered.

We have found the error. As you can see in the circuit diagram, an incorrect component was inserted in the sleep line. SN74LVC1G125 instead of SN74LVC1G126.
Now it works.

Thanks for the implicit review 😉

0 Kudos
Message 4 of 5
(163 Views)
Solution
Accepted by topic author technixtp

Glad I could help! 😀

Sometimes talking with someone is all you need to realize what's going on!

Nathan
NI Chief Hardware Engineer
0 Kudos
Message 5 of 5
(159 Views)