FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

FP-2000 Error: Serial port receive buffer overflow


I am trying to get an old system working, that was set up by someone else, and upon running our program we get the following error:




Error 63 occured at TCP Open Connection in Host>Host

Possible Reason(s):

LabVIEW: Serial port receive buffer overflow


LabVIEW: The network connection was refused by the server



We are running an FP-2000 directly hooked up to the computer by ethernet, can anyone help us?

Thanks in advance!



0 Kudos
Message 1 of 4

Hello Robzored,


A common reason for that error is that there is no real-time application running on the FP-2000 controller when you are attempting to communicate to it from your host computer. Can you make sure the real-time executable has been deployed to the controller?

0 Kudos
Message 2 of 4

We're not sure if a real-time appliction has deployed to the field point module.


To be honest this is a labview program written over a decade ago by people who are no longer here. We tried writing our own basic labview program and it worked just fine with the fieldpoint module, however immediately upon trying to run the old program (whether as an exe or through labview) the program immediately spits out the error 63. For a while it had a different error if we ran it using the vi, that popped up after about 30 seconds or so


"Error 56 occured at TCP Open Connection in Host>Host

possible causes:

Labview: the network operation exceeded the user-specified or system time limit"


But that error has ceased to appear.


Hopefully there is something obvious we're missing, because the old program is poorly commented

0 Kudos
Message 3 of 4

Hello Robozored,


From what you have told me, it still sounds like there is no real-time application on your FP-2000. This would cause a time-out (error 56) by not accepting a connection from your computer, and as we discussed before could also cause a serial buffer overflow on the host (error 63). If you still have the old LabVIEW project and that contains the FP-2000 as a target, you might find these articles helpful in making sure that the application is running:


As an additional consideration, the FP-2000 is moving into obsolescence. Would you say that, moving forward, you simply are looking to get the old code running on the FieldPoint device? If you plan on creating new applications with a real-time controller, I would highly recommend looking into developing on the cRIO platform instead. 

0 Kudos
Message 4 of 4