FIRST Tech Challenge Discussions

Showing results for 
Search instead for 
Did you mean: 

Error 1 occurred at Get Queue Status in NI_LVConfig.lvlib:Get File

Go to solution

Hello. I am a teenage in High School who is on an FTC team. After programming the program chooser on my robot and getting teleop to work and everything, I went back to Autonomous programming. Programs that worked before all of a sudden stopped working and gave me this error:

Error 1 occurred at Get Queue Status in NI_LVConfig.lvlib:Get File>NI_LVConfig.lvlib:Close Config>>>>

Possible reason(s): LabVIEW: An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.

MacBook Pro using LabVIEW 2012 with the FTC Toolkit installed

My vi is very simple an is meant to work with a Tetrix NXT robot. It's part of a robot project based off of the Ranger template. I'm very inexperienced with LabVIEW so I need detailed instructions on how to fix this.

0 Kudos
Message 1 of 3

Hi sk8er_steve,

Use the ctl-H feature and read about the 'Move For Distance' vi you are using in your code. You should see that you have specified a 1 in the distance input - that represents only 1/4 of a degree of rotation....was this your intent? I assume that you have installed the motor encoders on your motors. If not, then you should just be using the regular 'Move DC Motor' vi for a specified time and power.

Bottom line:  What are you wanting this autonomy to do?

Message 2 of 3
Accepted by sk8er_steve

I actually figure it out. I tried several different methods for making the motors move including the move DC motor vi. All worked previously and then stopped working. The problem was disk permissions In the LabVIEW Data folder. I guess I should've mentioned that I was using a Mac.

0 Kudos
Message 3 of 3