FIRST Robotics Competition Documents

Showing results for 
Search instead for 
Did you mean: 


I was trying to install FRC Game Tools using NI Package Manager (NIPM). When the installation finished, it asked me to reboot my PC, which then gave me a BSOD, with the error: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED, and what failed was the nipcibrd.sys file - National Instruments PCI Bridge Driver at C:\WINDOWS\System32\drivers\nipcibrd.sys.

I tried reinstalling Windows, and I successfully installed Game Tools without any errors. However, as soon as I tried installing anything that requires a reboot to finish the installation, particularly Docker, I was met with the same error. I have upgraded all my NI products in NIPM to the latest version and updated Windows to the latest version, yet the error persists. 

I tried disabling nipcibrd.sys using Autoruns, but then my PC would get another BSOD with INACCESSIBLE_BOOT_DEVICE.


The following are some information regarding my device:

OS Name: Microsoft Windows 11 Pro
OS Version: 10.0.22000 N/A Build 22000
OS Manufacturer: Microsoft Corporation
OS Configuration: Standalone Workstation
OS Build Type: Multiprocessor Free
Registered Owner: N/A
Registered Organization: N/A
Product ID: 00330-80000-00000-AA810
Original Install Date: 12/4/2021, 1:50:03 PM
System Boot Time: 12/14/2021, 4:35:33 PM
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: VivoBook_ASUSLaptop X421IAY_M413IA
System Type: x64-based PC
Processor(s): 1 Processor(s) Installed.
[01]: AMD64 Family 23 Model 96 Stepping 1 AuthenticAMD ~2000 Mhz
BIOS Version: American Megatrends Inc. X421IAY.305, 7/31/2020


Please help me resolve this issue.

Active Participant
Active Participant

I am currently having a similar issue. I got a new laptop with an Intel i7-1260p CPU.


I installed several LabVIEW versions from 2018 to 2021 including many hardware drivers (which results that PXI Platform Support and thus the driver nipcibrd.sys is added).


But as soon as I activate anything from the Hyper-V support after the LabVIEW driver-installations (like the Windows package VM platform) I get a BSOD in Windows 11 like mentioned above. In Windows 10 it is fairly similar, just without the BSOD, but Windows will not start with the combination Hyper-V active AND NI hardware drivers. Even an update of the NI PXI Platform Services 22.5 did not solve the issue.


By chance I deactivated the VT-d support (i.e. the intel(R) virtulization technology for directed I/O) and as strange it has been after that no BSOD anymore.

Perhaps this will work for others that might experience similar issue.


I opened a support request at NI, lets see if they can come up with a fix.

Kudos are welcome...