FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Deployment Problem

While attempting to deply our program in LabVIEW, we get the error message "FPGA_SystemAsync VI Agent.vi is This VI is broken or otherwise not in a deployable state".  I have tried reimaging the roboRIO, reinstalling the firmware, reinstalling and LabVIEW.  I do not know if it is related, but the lights for the DS Radio and Bridge are not lit up in the Driver Station.  I do show robot communication, and I am able to ping the robot.  The deployment starts, but halts when it reaches FPGA_SystemAsync VI Agent.vi.  On the roboRIO, the Power light is solid green, the COMM light is solid red, and the RSL light is solid orange. Thanks for any help you can give me!

0 Kudos
Message 1 of 5
(6,089 Views)

Hi amays,

For the roboRIO lights, the COMM light is indicating that it has communication with the driver station, but no user code.  The RSL light indicates that the robot is on and disabled.

This page is a great reference of the various status lights and what they mean: http://wpilib.screenstepslive.com/s/4485/m/24166/l/144972-status-light-quick-reference

Could you deploy the LabVIEW program before making any changes to it?  You can create a new project to test this.

Regards,
Kelly B.

National Instruments
0 Kudos
Message 2 of 5
(4,385 Views)

We have tried to create 3 separate projects, and we always get the same error message.  I am assumiing that since it is a VI, it is a LabVIEW issue.  Although Robot Main does not show any broken connections, the instant we run it, FPGA_SystemAsync VI Agent is listed in the error box and is broken.  There are actually three VI's listed as broken, the other two being "Details Display Dialog" and "Not Found Dialog".  The pictures below show the three VI's.  The first image shows that the error in "FPGA_SystemAsync VI Agent" is related to the Watchdog functions.  We have made no adjustments to the last two projects we have run: they are the default pre-programmed projects.

Labview 1.PNGLabview 2.PNGLabview 3.PNG

0 Kudos
Message 3 of 5
(4,385 Views)

I wonder if you installed on a machine that had last year's FRC 2014 on it?  Or maybe you copied code from a machine you used last year?  Your first screen shot with the Watchdog.Immortal and Watchdog.Kill node looks like old code to me.

I would suggest you try an install on a clean machine, or uninstall all NI software and reinstall LabVIEW for FRC 2015 .

0 Kudos
Message 4 of 5
(4,385 Views)

So I did a "complete" uninstall of all things National Instruments on my PC, reinstalled all of the NI FRC software, and tried a new program.  I still got the same error message.  When I started scrounging through files and folders, I found quite a few (3 GB worth) that looked like it was too outdated to be part of a recent installation.  I once again did a complete uninstall, this time going throught the Program Files folder, the LabVIEW Data folder in users, and any other place I could find anything related to NI.  Once I removed all of that. I rebooted and did a new installation.  By the ends of the day, I was finally able to build a project and fully deploy it.  I find it unusual that not only did the install package not seek out and modify/delet these old folders and files, but even running an uninstall did not remove them.  At least my anxious programmers can get to work.  Thanks to those who offered suggestions!

0 Kudos
Message 5 of 5
(4,385 Views)