FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Driver Station CONNECTION ERROR

We are having trouble wirelessly connecting our rRIO to our dirver station.

     We were able to image and format the rRIO using the new USB port, plus we could also run the code through the USB and flash it to the robot. We were also able to set up and configure our router and the IP settings. We are pretty sure we can connect to the router for we see the connection in the computer.

     The issue is that the moment we disconect the USB, we lose connection. On the driver station diagnostics the DS radio light won't turn on. It suggests that we check power, configuration, and the cabling between the driver station and the router. We've tried all these, but it still won't work. We've tried connecting wirelessly to the router, through ethernet to the router, and we've even tried connecting directly through ethernet to the rRIO. None will work. We think that the issue is in the ethernet port on the rRIO.

     We would very much appreciate any knowledge regarding this topic.

0 Kudos
Message 1 of 11
(8,737 Views)

Hello TeamDRIFT,

What is the IP address of your roboRIO? After you image the roboRIO over USB, you should be able to connect to the roboRIO using the IP address. The IP address will be roboRIO-1234.local but replace 1234 with your team number. When working through routers and switches you will also want to check whether or not your computer can even see the roboRIO. Try opening the cmd line prompt (cmd.exe on a windows computer) and then try the command "ping roboRIO-1234.local" where 1234 is replaced with your team number. If you can ping the roboRIO without any packet loss - then your computer can see the roboRIO. Then try connecting to it by setting the team number in the driver station.


Let me know if this helps!

Message 2 of 11
(5,288 Views)

Thank you Earl_of_Lemongrab.

We pinged the rRIO successfully and it showed connection with no data loss. Nonetheless, our connection lights on our driver station give us red for communication and the driver station is telling us that there is no robot connection. The DS radio light still won't turn on.

If you have any suggestions as to what we might try now, please let us know. We would very much appreciate it.

0 Kudos
Message 3 of 11
(5,288 Views)

Is this with or without the wireless bridge? In your original post you mention having tried both. Lets focus on connecting using a wired Ethernet connection for the time being.

What are the LEDs doing on your roboRIO? If it is connected and sitting idle with no running code it should have a solid green power LED, a solid red COMM LED, and a solid yellow RSS LED. Are your LEDs different?

Have you entered your team number into the driver station? You do this by clicking the gear icon amongst the tabs on the left side of the window. There is a variable here to enter your team number and this must be done to communicate with the roboRIO through the driver station. The communication LED should then turn on after a short time.

It might also be helpful to see a screen shot of the ping results, so we are looking at the same information.

0 Kudos
Message 4 of 11
(5,288 Views)

First of all. Thank You so so so so so much for Your consistent help. It has been of much use to us and we really appreciate it.

Our yellow led says RSL (there is no RSS on our roboRIO) and the team number is in the Driver Station. We only pinged it with the wireless bridge. We expect that if it works wiressly then the ethernet conection would work too.

This morning, we reinstalled the Driver Sation on one of the computers and the robot light turned on randomly for a while, but it went off before we could try connecting through the D-Link.

0 Kudos
Message 5 of 11
(5,288 Views)

We are really confused. The ethernet port the manual told us to conect the cable to, and the one we've been using all along is, according to the Control System Layout given to us by FIRST, where you connect the camera. Which is the actual port we have to use???

0 Kudos
Message 6 of 11
(5,288 Views)

UPDATE: We went over to another team's workplace because they have a mentor who knows a good deal about software (we don't have any software mentors), and they were trying to connect for the first time just when we arrived, and they followed the same exact steps we have tried just around a billion times and on their first go, it worked. We then tried using our computer to connect to their rRIO and we were successful the first time too. We are beginning to feel convinced that our issue has to do with our rRIO initself rather than our connecting to it. It might be improperly wired, so we'll get our guys in elecronics to check on that tomorrow. But we suspect that our rRIO might be faulty.

Is there any other possible explanation? Is there a set way to check whether our rRIo works?

0 Kudos
Message 7 of 11
(5,288 Views)

Just so I understand – Another team’s roboRIO works with their computer. Their roboRIO also works with your computer. Did you try using your roboRIO with their computer?

I think checking the system wiring is a smart troubleshooting step, so please do that. I also think you should try connecting to the roboRIO directly without the router: Connect your PC to the roboRIO directly using an Ethernet cable from the port on the PC to the port on the roboRIO. It is possible there is a problem with the router or wiring to the router.

If you still can’t connect with a direct Ethernet connection to your computer, you can call the National Instruments phone support team at 866-511-6285 and they can work with you over the phone.

0 Kudos
Message 8 of 11
(5,288 Views)

Thanks for all Your help Earl,

Today we were able to bring our electronics board to the other team's lab. There, we learned that the issue was in our D-Link, not our rRIO, which is much more manageable 🙂 We know because we replaced their D-Link with ours and their robot wouldn't work with our D-Link, but ours would work with their's; so we figured it was the D-Link. We'll try reconfiguring it to see if it works. If you have any suggestions as to what to try, we would appreciate it. Thanks again for all your help.

0 Kudos
Message 9 of 11
(5,288 Views)

Thanks for all Your help Earl, we are just letting You know that our issue was resolved. It turns out our D-Link was not properly configured because we had the wrong configuration software on our computers. We were able to copy over the program that the other team that has helped us was using and everything is working fine now. Again, thanks for everything.

0 Kudos
Message 10 of 11
(5,288 Views)