FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Image CRio

When attempting to image our crio, we get a dialouge box that says unable to reset the ip address of the crio, we bagged our robot yesterday unable to resolve the problem. Since then we have been trying to resolve the problem using a different crio on a test bench we made earlier, we are still running into the same problem. On our test bench we have a 8 slot crio and have reset it, tried running it in safe mode, and made sure the ip reset switch was off. We checked our firewall and have gone through just about every troubleshoot we could find. Before we tried formating the crio we had a series of problems where our code apparently had to much in it and it was starving other loops like the drive causing our robot to enable but not work. So beliveing that there was too much on our crio we decided to format it, now we cant even connect our crio to the driver station.

Please Help,

0 Kudos
Message 1 of 2
(3,537 Views)

From the imaging tool it looks like your cRIO is currently set to an all 0s IP address.  A lot of firewalls and routers will block that these days (which is why the IP doesn't reset to all 0s on newer cRIOs).  I would suggest opening up Measurement and Automation Explorer - navigating to the cRIO and trying to manually set the IP address to somethign on the same subnet as your laptop.  Then try to run the imaging tool again.

Kevin Fort
Principal Software Engineer
NI
0 Kudos
Message 2 of 2
(2,016 Views)