Driver Development Kit (DDK)

Showing results for 
Search instead for 
Did you mean: 

installing a .inf file on Labview

Go to solution

Hello people I am trying to control a pololu Tic T825 stepper motor controller using labview 2019 SP1 64 bit. I am using windows 10 Enterprise 64 bit.


The controller is visible on the device manager and can be controlled successfully using the following drivers:


The company say that they don't have any labview drivers and so I assumed that I need to generate my own using 

The NI-Visa Driver wizard. (Is this the correct way to go?) I was able to successfully find the the relevant  USB connection and was able to generate what I named Prefix.inf


I have been struggling to sign the catalog (.cat) file and perform the installation and I wonder if people can point out what I am doing wrong (assuming going to the NI-Visa Driver wizard was correct) I followed the instructions on:


Making a catalog file with:


Inf2Cat /driver:"C:\Users\ARTOF\Documents\National Instruments\NI-VISA\pololu\"/os:8_X64,8_X86,Server8_X64,Server2008R2_X64,7_X64,7_X86,Server2008_X64,Server2008_X86,Vista_X64,Vista_X86,Server2003_X64,Server2003_X86,XP_X64,XP_X86,2000


I made the cert: (without a password)

makecert -r -pe -n "CN=RobertS" -eku -sky exchange -sv RobertS.pvk RobertS.cer


I converted the files to .pfx

pvk2pfx -pvk RobertS.pvk -spc RobertS.cer -pfx RobertS.pfx


I than installed both the .cer and the .pfx files into the Trusted Root Certification Authorities


finally I tried to sign

signing the file: SignTool sign /f "C:\Users\ARTOF\Documents\National Instruments\NI-VISA\pololu\RobertS.pfx" "C:\Users\ARTOF\Documents\National Instruments\NI-VISA\pololu\" 


I get an error saying: SignTool Error: No certificates were found that met all the given criteria.


from googling this error suggests that my certificates are not valid or something but they are in the  Trusted Root Certification Authorities folder. Also I of course can't install the .inf file until this is resolved.


I have attached all the relevant files if this is useful.


I would appreciate  any ideas or feedback on how to resolve this.


Thank you in advance





0 Kudos
Message 1 of 9

Hello folks,


I see this has scared away a lot of people away. I found a way round this problem by disabling the driver writer check on windows 10. Documentation on how to do this can be found here:


I got it to work with the first option. I then needed to pick the .inf file from the device manager by right clicking on the original USB driver and selecting the .inf file.


So happy days, NI visa now displace a raw USB socket as shown in the attached NI_Max.png. The question now is how does one communicate with this. If I open labview, NI-visa does not see this (Only the COM ports appear if I create a constant VISA reference when opening VISA).


NI has some detailed documentation on using piping of a USB raw socket :


But I am not really sure how to figure out what to use. Pololu, have some help pages on communication through USB but they at least don't use the same language that is used in the NI article.


Could somebody point me in the right direction (maybe first) to how one configures NI-VISA in NI-Max to send the listed commands and make the device respond? I would also greatly appreciate some ideas on how to then use that automation in LabVIEW for an interactive program.


Thanks in advance


0 Kudos
Message 2 of 9
Accepted by topic author DrRob2020

Hi People, so I figured this out myself. In the end all of this driver signing was pointless as I didn't end up communicating with the stepper motor driver through MAX. I found it much easier to design a labview program around communicating with the controller though the built in command line communications. 


If somebody else want to control these stepper motor controllers simply start by installing the software that comes with the controller. After testing that everything works in their software you can make LabVIEW open the command line and use the built in communications  found here (Section 4.4) to make the controller do things:


I hope this speeds up others trying to interface with these.


Bye for Now



Message 3 of 9

Hey Robert,


I was trying to get my Tic T825 to work with LabView through serial connection and I'm encountering problems myself. So you think there's no other way of controlling the Tic through LabView? By the way I'm trying to control the Tic to move a linear actuator and it does work on the Tic Control Center Software.




0 Kudos
Message 4 of 9

Dear Ethan, The problem at least with USB is that there is a complex communication protocol, which I beleive the RAW USB port can't figure out on its own. I suspected (Maybe somebody from NI can confirm) that one could try to control the USB communication  through the VISA Test panel. I expected that one could go into Input/Output and the USB control tab and input the various bRequest, wValue... etc needed to communicate, as described in: Section 11. USB command encoding


Alas, I never got it to respond and I found just using the command line commands to be a simple way around it. One big disadvantage I see to the way I did it is that it seems I will only be able to communicate with 1 Tic controller per computer, where I guess with the serial approach you are taking  tou will be able to control as many as you have COM ports.


I have not experience trying to make it work in a serial configuration. I would naively assume that you just solder the right ports to the correct pin, and then just use the serial communication system in LabVIEW to write commands. What specifically is not working?






0 Kudos
Message 5 of 9

Hello Robert,


Did you try connecting the Tic through an Arduino? I tried just USB at first, but then I switched it to Arduino. My code is running fine and there is no error. But the Tic's light is red which indicates an error. So I think the signal I'm sending to the tic is to simple/code is to simple.





0 Kudos
Message 6 of 9

Hi Ethan, this looks very nice. I guess if it works then flashing red lights are not such a problem.


I guess you need to save a file or something with it's location so that your program knows where it is, or maybe you don't care about such details. I attached my code for the motor with the USB port in case you want to try it or it gives you ideas.


I hope it helps




0 Kudos
Message 7 of 9

Can you please save in earlier version? I have LV 2017 and cant open this file

0 Kudos
Message 8 of 9

HI viJay, please find attached

0 Kudos
Message 9 of 9