Distributed Control & Automation Framework (DCAF)

Showing results for 
Search instead for 
Did you mean: 

Editor as an Executable - Modules only appearing under 'Other'

Go to solution



With the help of this post, I have been able to successfully build an exe of the configuration tool using the template. I can add targets, engines and modules.


In the development environment it works fine, however, when I run the built tool, all of the modules appear in the 'Other' category. The modules appear in the correct categories (as set in the editor node class) in the default configuration editor found in LabVIEW.


I've tried to dig through and understand exactly where the category is pulled from but I can't really make head nor tail of it.


Has anyone else experienced this? Has anyone successfully built a config editor?


Many Thanks

0 Kudos
Message 1 of 2
Accepted by topic author niNickC

To any weary devs out there.


I found the solution.

There is a bug in the PL_class cache.lvlib.

discover class type.vi has a conditional disable structure changing the behaviour in the run-time engine:


discover class type.png


In development, 'classify plclass.vi' is called. In run-time 'indentify classes in memory.vi' is called.

Inside 'classify plclass.vi' (development environment), Get Category.vi is called:



This call is missing inside 'identify classes in memory.vi'. This results in the category inside the class cache being blank. This results in the modules being placed in the 'other' category.

A small modification to 'identify classes in memory.vi' fixes the problem. Add 'Get Category.vi' and bundle the result into the module cache:


Hope this helps someone out there!

Message 2 of 2