Distributed Control & Automation Framework (DCAF)

Showing results for 
Search instead for 
Did you mean: 

DCAF Tutorials

DCAF Problem Statement, Temperature Controller Demo, and Project Benefits


Hands-on Tutorial

The current DCAF Hands-on Tutorials with related code and solutions is available for download from the GitHub repository.



Video Tutorials


All of the DCAF related video tutorials can be found on the DCAF Youtube channel

Introduction to DCAF



Example Walk-Through



DCAF Engine Under The Hood



Creating a Static Channel Module Plugin


Collaborating on DCAF Development


authored by
Christian L, CLA
Systems Engineering Manager - Automotive and Transportation
NI - Austin, TX

Message 1 of 4



Thanks much for organizing the learning resources for everybody.  

While working on Step 9 of Hands-On 2, the following error was returned, when Configuration Editor is being initialized.  


Error during Hands-on 2.png

For debugging this error, a break-point was set inside "save cache.vi".  After the error occurred, Configuration Editor stops, and the VI remains open because of the brake-point.  Then, I made a copy of the VI "save cache.vi" with its input set as default at which the error occurred.  I found even just executing this VI returns the same error.  


Would anybody run into the same situation and stopped working Hands-on 2?   

0 Kudos
Message 2 of 4

Do you see this error when opening the DCAF Editor or when opening the TemperatureChamber.pcfg solution from the Editor?


I just verified, and can open this configuration file from the editor just fine.



Andres G

0 Kudos
Message 3 of 4

You mentioned the error happens in step 9:


"9. We want to configure the editor to search for modules in the path where our PID module was saved. From the DCAF Editor, navigate to Tools >> Edit Plugin Search Paths.... Add the next path as a search path: \Temperature Controller\Modules. Click OK for the editor to refresh the list of plugins available. Note: Add the whole modules directory as the simulation module is in that folder."


I just followed this step from my side and worked just fine. Maybe the path where these modules are located is too long in your computer? Have you tried copying and pasting the Modules folder to somewhere else (maybe your desktop) and then search again?

0 Kudos
Message 4 of 4