Distributed Control & Automation Framework (DCAF)

Showing results for 
Search instead for 
Did you mean: 

DCAF Editor error then LabVIEW crash

Go to solution

I'm trying to follow the Temperature Controller tutorial. I've installed all shown DCAF packages successfully.

Screenshot 2020-05-20 01.36.35.png

At some point in part A of tutorial, I add the add'l search path and press OK, the relinking dialog comes up plus the DCAF progress bar (see screenshot). At some point, LabVIEW errors and stops responding. Any idea what's the cause and how to fix it? Hopefully, folks out there or at NI have seen this issue.

Screenshot 2020-05-20 01.31.32.png

Screenshot 2020-05-20 01.29.57.png

Screenshot 2020-05-20 00.59.08.png

0 Kudos
Message 1 of 6

Did you download these files from the github repo (and if so can you link to the specific folder in the documentation repo)?


Are you able to open up the individual classes directly in LabVIEW?

Matt J | National Instruments | CLA
0 Kudos
Message 2 of 6

Download link: https://github.com/LabVIEW-DCAF/DCAF-Examples


I just noticed the Temperature Controller is included as an example with one of the DCAF modules I installed. I opened it and it fails the same way. I noticed loading Class 29 of 69 is always the culprit. Actually the error occurs if I launch the DCAF SCE from the LabVIEW Navigation go to Tools>>Edit Plugin Search Paths, do nothing, press OK button, the progress bar will fail loading Class 29.


I've not tried opening these classes. Would you explain how? the progress bar does not show what class is being loaded.

0 Kudos
Message 3 of 6
Accepted by topic author jorgeinSD

The numbers are kind of dependent on what exactly is installed on your machine but you can edit the configuration editor to show this information fairly easily. If you open the block diagram of the configuration editor and go to the "FindPluginNodes" case of the message handling loop, open the following VI (it's probably locked so you may need to press Ctrl+M).




In that VI there is a for loop where the classes are being loaded so you could just use breakpoints and probes to see what is happening but you can also make the following changes and the progress bar will print which class is being loaded.




All of the names will just correspond to .lvclass files in some subfolder of one of the search paths so once you find which one isn't loading you can just try to open that .lvclass file. If you can't find the class that the framework is loading, let me know and I can help.

Matt J | National Instruments | CLA
0 Kudos
Message 4 of 6


Solved ! It was the TDMS datalogger editor node. The class wanted to compile on closing; got same error and crash. See screenshot.

I uninstalled this module and I've moved past this in the tutorial.


I wasn't planning to use TDMS logging so this solution suffice but if I can help try anything else let me know.

thank you !


0 Kudos
Message 5 of 6

I have that package installed on my machine so my first guess would be that it was just an issue with the installation and reinstallation would fix the issue but if you weren't going to use the module, it probably isn't worth spending a lot more time.

Matt J | National Instruments | CLA
0 Kudos
Message 6 of 6