Digital Multimeters (DMMs) and Precision DC Sources

cancel
Showing results for 
Search instead for 
Did you mean: 

Keithley 2000 Sampling Rate

Hy folks,

 

I need a bit help from anyone, Firstly I am new to Labview and I have to logg the data using keithley 2000, I dont have any connection problem, I am able to run NI "Read single" and "Read Multiple" vi's sucessfully. Now the Problem I have is the sampling rate, which I need to be an input between 1-10 samples per second, I have attached the VI which I created to record I no where get the expected output Its always timeout error. I have one more VI in which everything is inside while which I use to Logg now that works but it gives one reading every 1 second or more. Kindly help

 

Settings I am using is: RS232, serial to usb adapter, Baud rate 19200

 

Thanks in advance

regards

Kunal

0 Kudos
Message 1 of 8
(8,020 Views)

Hi Kunal,

 

which driver are you using for your data logger? Can you attach it in your post or provide a link otherwise the VI is not working.

 

Regards

Branni

0 Kudos
Message 2 of 8
(7,966 Views)

How much data are you trying to collect?  Over what period of time are you collecting this data?


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 3 of 8
(7,961 Views)

Hy Branni, I am using the one downloaded from NI website the Plug and play IVI I think... I have attached the zip file 

0 Kudos
Message 4 of 8
(7,957 Views)

Hello Crossrulz, I need to collect for minimum 5-10 minutes and If possible sometimes till 30 minutes but sample rate must be minimum 10 Samples/Second. Looking forward for any help. Thankyou

0 Kudos
Message 5 of 8
(7,956 Views)

I cleaned up your VI some.  One of the biggest things I saw was that you were closing the driver inside of your loop.  You shouldn't close until after you are done with it.  So I moved it to after your loop.  Also made your formatting of the data a lot simpler.

 

Reading a DMM measurement and saving it to disk in 100ms seems like it will be a slight stretch.  We may have to go to a Producer/Consumer setup to move the file writing into another loop so that the acquiring of data is (somewhat) consistant.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
Message 6 of 8
(7,951 Views)

Hello Crossrulz, your solution is acceptable upto some point as I am able to get a average of 5 readings/second, whatever the sampling value I give more than 5 sample/sec I get a sequence of 6-6-5 readings/second. Looking forward for further help. 

Have you tested with your multimeter how many readings you get ??

0 Kudos
Message 7 of 8
(7,940 Views)

I don't have a DMM here to test with.  I am a little surprised you are only getting ~5 samples/second.  I thought it would be closer to the 10.

 

Your problem is that you are getting too much data for the meter to hold in its buffer, so we can't just tell it to sample at a specific rate and gather the data 5 minutes later.  But at the same time, we are struggling with talking to the meter fast enough to get the rate that you want.

 

Try taking out the code for the triggers.  Hopefully the meter will retake a measurement each time you perform a single read.  If that doesn't work, I'll have to dig into my programmer's manual to look up some commands.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 8 of 8
(7,935 Views)