Developer Center Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

Solved!
Go to solution
Highlighted

Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

Hello Everyone,

I'm having some troubles with installing Third Pary Licensing & Activation Toolkit in LabVIEW 2014 SP1 (64-bit) on my PC.

The error message says:

Error Code: 42

Error Source: PreInstall.vi<ERR>

This package requires administrative privileges to install.  Please restart VIPM and LabVIEW as an Administrator to continue installation.

I tried several times by running:

- VIPM as Administrator and letting VIPM to launch LabVIEW

- Both VIPM and LabVIEW as Administrator directly

- Setting compatibility option to Windows 8

- Disabling UAC completely

System info:

- LabVIEW 2014 SP1 14.0.1f3 (64-bit)

- VIPM 2014.0.1 (build 1967)

- Windows 10 64-bit

I am able to install the package on LabVIEW 2012 SP1 (32-bit).

Any suggestions? Does the toolkit support LV 64-bit?

Thank you!

Did you know LabVIEW can control industrial robot arms? - www.digimetrix.com
0 Kudos
Message 1 of 9
(5,467 Views)
This widget could not be displayed.
Solution
This widget could not be displayed.

Re: Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

Hello,

Thank you for bringing this to our attention.  TPLAT is supported in LabVIEW 64-bit, however there is a bug in the VI Package causing the error on 64-bit installations.  The package has a pre-install action that checks write access to a protected folder.  The folder it is supposed to be checking is "C:\Program Files (x86)\National Instruments\_Legal Information" however the installer is inproperly attempting to write to "C:\Program Files\National Instruments\_Legal Information" which does not normally exist.  Since the folder doesn't exist, the pre-install action is throwing an error.

The workaround is to simply create an empty folder at the location "C:\Program Files\National Instruments\_Legal Information" and re-attempt installation.  I'll report this to R&D so this hopefully can be resolved in the next package update.

Thanks again, and please let me know if you still have trouble after trying my workaround.

David

Message 2 of 9
(3,343 Views)

Re: Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

Hi David,

It worked!

Thank you,

Nikita.

Did you know LabVIEW can control industrial robot arms? - www.digimetrix.com
0 Kudos
Message 3 of 9
(3,343 Views)

Re: Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

Hi David,

The workaround didn't work in my case. I'm using LV2015SP1 32-bit in W10.

I hope you can help.

Jorge

Legal Info.jpg

0 Kudos
Message 4 of 9
(3,343 Views)

Re: Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

What error is reported by VI Package Manager during installation?

0 Kudos
Message 5 of 9
(3,343 Views)

Re: Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

Error 42.

There's only one user account in this laptop, mine as admin.

Screenshot

TPLAT error 42.jpg

0 Kudos
Message 6 of 9
(3,343 Views)

Re: Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

Despite having admin rights for your user account, you still need to choose to run applications with admin rights enabled in Windows.  Microsoft introduced this behavior in Windows Vista to protect users.  It is somewhat common to now need to elevate permissions when installing software either by running the installer as an Admin or via a UAC prompt during installation.

Please right-click on the VI Package Manager EXE/shortcut and choose to 'Run as Administrator' prior to installing the TPLAT package and I'll bet you won't see Error 42.

-R

Message 7 of 9
(3,343 Views)

Re: Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

I'm glad I didn't bet !!

Thanks a lot !

Jorge

0 Kudos
Message 8 of 9
(3,343 Views)

Re: Error Code: 42. This package requires administrative privileges to install with LV2014SP1 64-bit

No problem.  Glad you're up & running!

0 Kudos
Message 9 of 9
(3,343 Views)