DIAdem

cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to Run Script in DIAdem 2018

Solved!
Go to solution

Hello,

 

I want to run script in DIAdem Base 2018. I select the script I want to load in. I select the mf4 measurement, and an excel file. 

Then I get the following message, that the measurement file is wrong. Issue can be seen in the attached pictures.

Has this problem occured by anyone? What is the solution?

 

Pictures in row: dia1 -- dia22 -- dia32 -- dia42 -- dia5

 

Best Regards,

 

Gábor

0 Kudos
Message 1 of 9
(773 Views)

Hi Gábor,

 

It is difficult to help here without detailed information. In the end it seems to be a problem with the MF4 file. Here some possible reasons:

 

The MF4 DataPlugin is not installed.

The installed MF4 DataPlugin is too old.

Something failed in the script where the file was selected.

 

Questions:

Did this work in the past on this PC with this file?

Can you load this file directly (without script)?

Is the MF4 DataPlugin installed and if so which version is it?

 

Greetings

Walter

0 Kudos
Message 2 of 9
(741 Views)

Hi Walter,

 

Thank you for the quick reply!!!!

 

DIAdem was installed yesterday on this PC for the first time, and also I'm new to the software.

 

To answer your question, i can't load the MF4 file. To be specific i can't even select it, maybe because the missing DataPlugin you mentioned.

 

Here is a screenshot of the DataPlugins, which i can see in DIAdem. Where can I download the one for the MF4 format?

 

Greetings,

Gábor

0 Kudos
Message 3 of 9
(724 Views)

Hi Gábor,

 

Yes it seems that the MF4 DataPlugin is not installed. You find the installer here:

 

https://www.ni.com/de-de/support/downloads/dataplugins/download.asam-e-v--dataplugin-for-mdf4.html#4...

 

Greetings

Walter

0 Kudos
Message 4 of 9
(719 Views)

Hello Walter,

 

Which version should i download?

 

2022 Q4 or 21.1 or 19.0?

 

Thanks!

 

Gábor

0 Kudos
Message 5 of 9
(715 Views)

Hello Gábor,

 

The latest one: 2022 Q4

 

Greetings

Walter

0 Kudos
Message 6 of 9
(713 Views)

Hi Walter,

 

I tried it with the 2022 Q4, but i get the same error.

 

I messaged my external colleagues to give me a DataPlugin i can use, they did that.

They sent a Plugin ("Labelliste_Import") they used last year, and it was working on the DIAdem 2020 version.

My version is 2018. I tried to import it in the DataPlugin options, but i get a message that the Plugin is not compatible with the 2018 version. See attachment please.

 

Is there ANY way i can convert/update/change this DataPlugin OR my DIAdem2018 to be compatible?

 

Thank you!

 

Best Regards,

Gábor

Download All
0 Kudos
Message 7 of 9
(668 Views)
Solution
Accepted by topic author gabor.beke.avlhu

Hi Gábor,

 

In general, DataPlugins can be developed by anyone. On our NI web page, we provide those which are typically developed by NI. The "Labelliste_Import" DataPlugin is not from the NI Web page and created by someone and with that I have no information about this DataPlugin.

 

To solve you have two options:

 

Option A)

Recreate your DataPlugin to support your DIAdem version. In case of a VBS DataPlugin this is very simple. But I assume your DataPlugin is a C++ one and then the effort is much higher.

 

Option B)

Upgrade your DIAdem version to DIAdem 2020 or higher.

 

Greetings

Walter

Message 8 of 9
(665 Views)

Hello Walter,

 

It seems that the job what we execute needs the newest version of DIAdem. We have DIA2022 right now.

 

But you were very kind helping me to solve the issue with 2018. Thank you very much!

 

Best Regards,

Gábor

0 Kudos
Message 9 of 9
(620 Views)