From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

DASYLab

cancel
Showing results for 
Search instead for 
Did you mean: 

Data Overrun Error using MCC DRV and USB-1808X

Solved!
Go to solution

Hello,

 

I attempting to run 7-8 channels at 200 kHz using MCC USB-1808X and DASYLab 2016. Almost immediately after starting my test, I receive the following error message.

 

USB-1808X (Device number 1)

Dev1-Ai0

Data Overrun - data was lost.

DASYLab Version: V14.0.1.721

DASYLab Driver Version: 14.1.0.0

DaqDevInfo Version: 2.9.4.0

Universay Library Version: 6.74

 

My current worksheet for troubleshooting this issue is simply the DAQ analog inputs (Channels 0-7) to a y/t chart with 8 inputs. Each analog input is open, but the final test will have amplified strain gauge signals for each input. That said, I uploaded a copy of the worksheet to this post.

 

The DAQ is set up in InstaCal for differential input. Switching the number of channels and sample rates, I found that the driver crashes when I select more than ~1 MHz accumulative samples/sec. So, I can run 4-5 channels at 200 kHz without a crash, but 8 channels cannot be fast than 130 kHz. After managing Windows updates, updating the MCC driver to 6.74, using different USB ports and cables, I was unable to run 8 channels at 200 kHz, despite the data sheet stating that each channel can handle the speed simultaneously.

 

I tested the same worksheet and DAQ using a Windows 11 laptop and did not experience the driver crash. Am I misunderstanding the 1808X's capabilities, is this a driver compatibility issue, or a PC hardware limitation?

 

I have included my redacted setup information below.

 

---------- Report Start ----------

Program = DASYLab 2016, Release 14.0.1 (Build 721) - 32 bit English [Feb 1 2018]

Serial Number = XXX
User Name = XXX
User Admin = Yes
User Guest = No
Company = XXX

Language = English
Version = Full
Type = Customer
Dongle = No
instruNet = Yes
Sequence Generator = No
Power DLL = No
Net 10 = No
Net 20 = No
Network = No
Interbus = No
AddOn1 = No
Rainflow = No
Layouter = Yes
Softing CanBus = No
NI CanBus = No
OPC = No
Solartron = No

Operating System = Windows 10
OS Version = 10.0 - Build: 19045
Country = United States
Processors = 4
Processor Type = Intel(R) Core(TM) i5-6440HQ CPU @ 2.60GHz
RAM Size = 4194 MB
Display Driver = ?
Screen Resolution = 1920x1080
Colors = 4294967296 (32 Bits)

Extended DLL1 = MCCDRV_I.DLL
Extended DLL2 = DLAB_UX2.DLL
Extended DLL3 = DLAB_UX3.DLL
Extended DLL4 = DLAB_UX4.DLL
Extended DLL5 = DLAB_UX5.DLL
Extended DLL6 = DLAB_UX6.DLL
Extended DLL7 = DLAB_UX7.DLL
Extended DLL8 = DLAB_UX8.DLL

Driver Name = Sounddrv.dll
Driver Version = Sound 2016.0.0/Feb 1 2018
Installed VxD Driver = -----/-----

----------- Report End -----------

 

Thank you in advance for the assistance.

0 Kudos
Message 1 of 8
(451 Views)
Solution
Accepted by topic author SybQ

Hello,

 

You won't like this, but your worksheet ran fine with a USB-1808X on my old HP desktop (circa 2010) with an Intel i7-2600. Try a different USB port and cable; if connected through an external USB hub, bypass it and connect directly to the PC. If you get the same results, I suspect you have a background process blocking our driver from servicing the board. 

0 Kudos
Message 2 of 8
(424 Views)

I just tried a third USB cable and all three ports on the machine but received the same error message. My fear was there is an app or Windows background process interrupting the data flow, but tracking that down is outside of my scope right now. 

 

The setup was working fine a few months ago, but we didn't use all channels, if I recall correctly. I'm thinking my next step is to wipe the machine and do a fresh Windows install to see if that remedies the issue.

 

Thank you for confirming. 

0 Kudos
Message 3 of 8
(408 Views)

I seem to recall that the driver was updated for dasylab 2020. It might be worth trying a more recent version.

--cj --DASYLab Pro -- Retired --- I am no longer employed by NI or Measurement Computing. My opinions are just that, seasoned by 25+ years of working with DASYLab. Please contact www.MeasX.com or www.mccdaq.com for active support options.
0 Kudos
Message 4 of 8
(402 Views)

I'll need to run purchasing and upgrading to a new version past my director, but it wouldn't hurt to try an evaluation copy to see if I run into the same issue. Thank you for the suggestion and information. 

0 Kudos
Message 5 of 8
(397 Views)

Sadly, running a test using v2022.1 did not help. Therefore, some program or process on the machine is causing the issue.

0 Kudos
Message 6 of 8
(379 Views)
Solution
Accepted by topic author SybQ

One thought... Have you disabled power management on the USB hub/port?

 

Windows likes to turn off ports when the computer is idle, but it uses interaction to determine idle, not programs actually running.

--cj --DASYLab Pro -- Retired --- I am no longer employed by NI or Measurement Computing. My opinions are just that, seasoned by 25+ years of working with DASYLab. Please contact www.MeasX.com or www.mccdaq.com for active support options.
Message 7 of 8
(374 Views)

Thank you for responding even after I flagged this post as resolved. I disabled USB power management in the device manager and the power plan, and it seems to have resolved the issue. My test setup has been up for almost an hour without throwing the error message. I'm going to complete a few more long "dummy" tests before I trust using the laptop/DAQ combo with critical data acquisition, but it appears this simple change fixed the issue.

 

Now I'm wondering why the power management setting started affecting the test setup to begin with. Perhaps a Windows update changed something small but fundamental...

0 Kudos
Message 8 of 8
(326 Views)