Actor Framework Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Actor Message Maker not showing up in Context Menu

I have a project in LV 2014 that has been working fine as far as the Actor Message Maker. I started modifying the code today and now the Message Maker is not showing up in the context menu. What do I need to check to see why this is not working?

 

Thanks in advance,
Eldon

0 Kudos
Message 1 of 6
(2,843 Views)

Hi Eldon,

 

Are you doing anything "unusual" with your AF library?

The first thing that springs to mind is if the version you depend on is not in vi.lib, or is in a PPL not built based on sources in vi.lib.

 

That's because the Message Maker tooling (at least in newer versions of LabVIEW - I don't know about 2014...) uses a couple of VIs to determine if it should appear, and that scans for vi.lib in the path (this is part of the path in PPLs).

 

See:

<LabVIEW directory>\resource\Framework\Providers\ActorMessageMaker\Support\Is Actor.vi

<LabVIEW directory>\resource\Framework\Providers\MessageMakerProvider\_Message Maker\_support\Inherits from an Actor.vi

 

This second VI can be modified to scan only for the parts of the path that you still have - removing the vi.lib if desired:

Change the path constant to change the behaviour when right clickingChange the path constant to change the behaviour when right clicking

Change the path constant to change the detection of an Actor, which determines the behaviour when right clicking on things.


GCentral
0 Kudos
Message 2 of 6
(2,814 Views)

CButcher,

Unfortunately, the VI files you make reference to do not exist. I do not have the folder paths that you are referring to. I do have a folder under LabView2014 that is ProjectTemplates/Source/Core/Actor Framework/Scripting/TwoTasksMetaDataObj. The two VIs that you are referring to do not exist in this folder.

 

As I mentioned, this use to work and nothing, as far as I know, has changed with reference to the Actor core. I do not use PPLs or anything else special. The class in question inherits from another class that inherits from the Actor core. If I look at the last inheritance, it refers to the Actor core located in "vi.lib".

 

Thanks,
Eldon

0 Kudos
Message 3 of 6
(2,799 Views)

I see - I guess they must have been placed there in later versions, and in 2014 they lived somewhere else, or had a different name/structure.

 

Do you know if you have any other changes made to Project Providers in your LabVIEW installation? Some VIPM packages install Providers, incidentally (although those are probably well tested).

 

I believe that it's possible for errors in one PP to prevent the proper execution of others, but I haven't tested this and it's been a while since I did any work with Proj. Providers.

I also couldn't point to a likely suspect in this case, but if you know something might have changed it's worth considering.

 

Beyond that, I can't think of anything obvious. If it previously worked, and now doesn't, clearly something changed. Without some idea of what, it's difficult to guess... 😕


GCentral
0 Kudos
Message 4 of 6
(2,792 Views)

I use AF Project Provider with LV2014 SP1. Sometimes the entries "AF-> Create Message" and "AF-> Create Child of Abstract Msg" disappear in the context menu after some messages have been created. I have to restart LV completely, then they will be available again ...

0 Kudos
Message 5 of 6
(2,789 Views)

Thanks for the suggestion but I tried that since that is pretty much SOP with LV.

Eldon

0 Kudos
Message 6 of 6
(2,786 Views)