NI Home > Community > NI Discussion Forums

Motion Control and Motor Drives

Reply
Member
se_mark
Posts: 2
0 Kudos

Problem using Interpolated Position Mode on EPOS2 from maxon motor

[ Edited ]

Dear Mr../ Mrs..

 

I have DC-motor with Encoder (4000 inc. pr. turn) and EPOS2 motor controller from Maxon Motor. I want to use the EPOS2 Interpolated Position Mode (IPT Mode), but can't find any examples anywhere. I have read read much of the documentation for the EPOS2 and also browsed the examples (there isn't any specific for the IPT mode). Furthermore I can get the Position Profile and Velocity Profile modes works - so there is hope ;-) The labview program is executed on my PC, communicates with the EPOS2 on a CANopen network, through a USB-CAN converter from IXXAT.

 

I have attached my program - this is only a test program where I buffer 2-4 values manually written values and starts the trajectory. I can initialise and send values to the buffer, but when I start the IPT trajectory the axis turns into Fault state and the motor does not move. If I clear Fault state afterwards it turns over to disabled state. I gues I have to specify some more parameters? But I don't know which ones. Furthermore I might think, that I should place the functions in the move case structure in a while loop or change the mechanical action in order to execute the whole trajectory?

 

Thanks in advance

 

Best Regards

Søren Mark

Member
Moses_Bro
Posts: 2
0 Kudos

Re: Problem using Interpolated Position Mode on EPOS2 from maxon motor

Hi,

 

Have you found any examples yet?

 

I think your errors are a result of your target position being initially too far away from your starting-actual position.  If there is too much of a discrepancy, then you'll get an error (common with other operating modes also).

 

I'm currently working on the same problem, maybe we can help each other out.

 

~Aaron

Member
Dave@Ventec
Posts: 92
0 Kudos

Re: Problem using Interpolated Position Mode on EPOS2 from maxon motor

Were you able to find a working solution - I am about to tackle this same problem with a EPOS2 and IPT mode.  Any guidance will be very much appreciated!

 

Regards,

David