VeriStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Custom Device FIFO

Solved!
Go to solution

Hi everyone,

 

I have a custom device that initializes without issues, but I can't figure out how to use it at run time. I used the Inline HW template to create the device. The system definition deploys to the FPGA target, but I can't seem to read from or write to the FIFO. For learning purposes, I am simply writing three true constants that activate three chassis LEDs. When I deploy to the target, the LEDs do not light up.

 

I created a VI using similar code which does not use VeriStand. The difference is that I use a while loop to read and write FIFO elements in the functional VI, whereas the custom device template generated a driver VI that uses a case structure and an enum to determine its mode. I must be doing something wrong... does anyone have any pointers?

 

Thanks

0 Kudos
Message 1 of 3
(3,806 Views)

Could you post the code you have so far?  It would be helpful to take an initial look.

 

Also, could you clarify what you mean by "the system definition deploys to the FPGA target"?  Do you mean that your system definition deploys to a system that uses an FPGA device?  Are you trying to communicate between your host system and the FPGA through the custom device?  If so, what kind of data communication are you trying to perform?  It may be possible to use either an existing custom device or avoid custom devices entirely?

 

P.S. - I'm going to ask the moderator to move this thread to the VeriStand forums, rather than LabVIEW.  It will get more attention from VeriStand experts there.

Cody A.
0 Kudos
Message 2 of 3
(3,777 Views)
Solution
Accepted by topic author MitchD319

After scratching my head for hours, I finally realized that I never wired a true constant to the control that actually starts my FPGA VI... oops! Thanks for your time.

0 Kudos
Message 3 of 3
(3,764 Views)