Troubleshooting Hardware

cancel
Showing results for 
Search instead for 
Did you mean: 

RoboRIO unrecoverable error (status light continuously flashes)

Solved!
Go to solution

We have a RoboRIO that the status light is continuously flashing and need the recovery file, or other solution, that I have seen mentioned online.  This started when the tried to install the 2021 image on kickoff day two Saturday's ago.  The image has since been updated and our other RoboRIO was imaged and is working.

 

We have followed all the instructions we can find (turn off firewalls, make sure nothing else is plugged in, start in safe mode, etc.)

 

NOTE: Tried calling the specific number on the website ( 866-511-6285, Monday through Friday, from 1:00–7:00 p.m. CST) last week Wednesday and left a message with no response.  Called again on Thursday and was on hold for an hour before being transferred and hung up on.  Called back again and and was on hold for another hour before transferred to someone that told me I had to contact AndyMark for support due to the serial number.  Contacted AndyMark Friday and found out today (Monday) that my best bet would be to send a message through the forums for assistance since I have already tried the phone number.  

 

Any prompt response would be appreciated!

 

Dan

FRC 6421

Message 1 of 7
(590 Views)

Hi Dan,

 

I'll send you a direct message with information on how to access that recovery file. 

 

For anyone that comes across this, please don't DM me specifically for access. Make a new post and an NI employee (you'll recognize us by the blue username at the top of our post) should find it and help you out. 

C. Weeks
Product Support Engineer
NI
0 Kudos
Message 2 of 7
(557 Views)

Hi DMrion,

 

You found the right spot. We are doing FRC support via the Forums.

I see you have tried a couple different troubleshooting steps. Does your RoboRIO enter safe mode properly or does it only restart with the status light blinking continuously?

 

This link has instructions on getting into safe mode (look in the troubleshooting section: https://www.ni.com/en-us/innovations/white-papers/15/imaging-the-roborio-and-common-troubleshooting-...

If you can get the RoboRIO to enter safe mode, connect it via USB to your computer and use the imaging tool to do a format and re-install the image. (directions also in the link above)

Regards,

Mike Altmann
Product R&D
NI
0 Kudos
Message 3 of 7
(555 Views)

Hi we have same problem too. We are Turkish FRC team 6064 from Turkey. I guess our roborio controller went brick state when we making update device image. Roborio status light is flashing continuously and we can not connect to roborio via ethernet or USB connectios. When I make a research on the web, found some informations about recovery image with USB flash drive. If posible please help me about USB recovery for roborio. Thanks.

0 Kudos
Message 4 of 7
(538 Views)
Solution
Accepted by topic author DMiron

Here is the solution that worked for use to make the roboRIO usable again:

  • Follow the ALL the roboRIO troubleshooting instructions: Imaging the roboRIO and Common Troubleshooting Techniques - NI
  • If this DOESN'T resolve the issue start a NEW forum message (Do NOT reply to this one.) and someone from NI should contact you.  Took about 24 hours for a response.
  • If you need the recovery.cfg file they will get to you.  Follow the instructions they provide.  NOTE: We needed a powered USB hub to finally get it to work.

 

Message 5 of 7
(528 Views)

Hi DMiron

 

Thank you for response. I did tried all of roboRIO troubleshooting instructions but its do not useful for us. Because we can not establish any connection with RoboRIO. Therefore I will write a new message to forum for recovery.cfg like you said. Thanks your coperation and good luck for FRC season.

0 Kudos
Message 6 of 7
(514 Views)

That imaging document is very outdated. It references firmware 2 vs 6. It has the roborio webdashboard for updating the firmware, rather then using the imaging tool

0 Kudos
Message 7 of 7
(490 Views)