Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

"First acquisition is not initiated" cRIO with NI 9253

Hello everyone, 


I am working on my thesis project. Basically, to perform HIL testing and validation, I have to use cRIO 9040 with the C-Series module NI 9253 to read one current signal, then perform some computation and then control an asynchronous motor accordingly.

I chose VeriStand 2020 rather than LabView to perform the HIL simulation, since the model and the controller to be validated have been programmed in Simulink, so that I only have to compile those models into executable .so files readable by VS.


I managed to create an .fpgaconfig file to configure the cRIO as FPGA in VS using the LabView FPGA XML builder node, but even though the inputs of NI 9253 appear correctly into the VS project, I am not able to read any value.

All the signals are stuck at 0 mA, and the module is not working at all. Its LEDs are flashing in alternating green rows, and this means that the module is powered on but the "first acquisition is not initiated", as stated in the "Getting Started Guide".

By the way, for some reason my VS project is able to read the Chassis I/O (I simply tried to read the value of the User Pushbutton and it works correctly), so it seems like the problem only regards the C-Series module. 


Additionally, I tried to build a LabView FPGA VI with the same basic functionality, and again, the same problem occurred, while the pushbutton works nicely. 


I am new to both LabView and VeriStand, and I am learning by myself, so I am probably missing something in the configuration of the current input module, but I cannot figure out what. Hope that you guys can help me with my learning process and thesis project. Thanks!


- Marco S.


0 Kudos
Message 1 of 2

Quick update: 


I was expecting a dumb error... Indeed it was 🙂 I simply did not notice the presence of the Start/Stop commands integrated in the module.



0 Kudos
Message 2 of 2