Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

cRIO fails to enter active mode, due to ethercat slave

Solved!
Go to solution

I have an ethercat slave (CS27 from HBM) connected to a cRIO 9068. If i right-click on the HBM device under the EthercatMaster and go to "Online Device State" i can set the state of the HBM first to "Pre Operational", "Safe Operational" and then "Operational". The CX27 indicates the operational stae with a LED.

 

But when i try to set the cRIO into "Active Mode" i get the error message:

- The NI Scan Engine could not be changed to Active mode because one or more slage devices failed to enter Operational state.

 

 

0 Kudos
Message 1 of 7
(6,265 Views)
Solution
Accepted by topic author ThetaMa

The problem is finally solved.

 

The problem was different sync manager layout between the HBM and cRIO (801 vs 802).

Thanks to HBM for providing a firmware update to support the layout used by NI!!

 

 

0 Kudos
Message 2 of 7
(6,176 Views)

Hi!

I hope I can get some help in this thread.

Trying to use a CX27 from HBM with LabVIEW 2015SP1 and a cRIO 9082. However when I try to add a new EtherCAT Slave Device "Target and Device"  I only get the message "Unknown Device".

I have tried to follow all instructions such as puting xml-file (Import Device Profiles) in the correct folder on RT target such as described here.

http://digital.ni.com/public.nsf/allkb/F24988795CA23831862578B700047080?OpenDocument

 

What I find from this thread is that someone actually seems to have solved the issue and got everything to work. I'm very intrested of knowing if there is something else that needs to be considered in order to find all EtherCAT signals on the CX27 unit.

 

0 Kudos
Message 3 of 7
(4,410 Views)

1. You need to update the firmware on the CX27 with a .bin file that supports the 802 layout. This file you find on the CX27 from the webserver.

2. From the Mx Assistant you need to select the 802 layout from the drop down menu in the EtherCAT settings. (nopt available if firmware is not updated.)

3. I did change some settings on the XML-file, but i dont remember what. Maybe your file works...

 

 

0 Kudos
Message 4 of 7
(4,404 Views)

Hi again!

I'm currently using the FW version (4.6.18.0) on the CX27 unit. I do see the option of selecting the 802 format in the dialog.

HBM have 4 different ESI xml-files on there webpage, however I do not understand the difference between them. In some way I guess the xml file is of major importance so that it is identified correctly when you try to add the device in LabVIEW project.

HBM-CX27.xml,

HBM-CX27_50.xml

HBM-CX27_100.xml

HBM-CX27_199.xml

Do you remember if you used  a manual or auto Source mapping and if you exported "your own" ESI file from MX Assistant program and used that xml file instead on the RT target?

0 Kudos
Message 5 of 7
(4,383 Views)

Manual vs auto is only a selection of how data is transmitted over EtherCAT, we use manual. This way we decide the order of the signals (isochronous) we send by dragging and dropping on the EtherCAT page.

 

I'm not 100% sure (only 99...), but i think the attached XML is the one I used when I imported the settings to the cRIO.

 

Try it, and let me know how it goes!

 

0 Kudos
Message 6 of 7
(4,380 Views)

Hi!

Your xml file works!

The major change in this xml file compared to the once proviced by HDM is the lines

    <Device Physics="YY">
        <Type SerialNo="#x0000" RevisionNo="#x0005" ProductCode="#x0802">HBM CX27(ET1100)</Type>
        <Name LcId="1033"><![CDATA[HBM CX27 (ESC ET1100) module for QuantumX]]></Name>
        <URL LcId="1033"><![CDATA[http://www.hbm.com]]></URL>
        <Info>

 

The product code must be set to 0802 to work for this format as you specified before. In the files proviced by HBM it is set to 0801...

Thanks for your support!

 

 

 

 

 

0 Kudos
Message 7 of 7
(4,358 Views)