Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

NI Linux RT - Disable or Remove Driver "Module"

Solved!
Go to solution
Highlighted

A follow on from a discussion here

 

I have a device that I want to use on my NI LInux RT Controller. This device happens to be an "HID" USB type thing. With a custom driver I can get to load into MAX when connected to Windows machine but not so easy on the Linux controller. 

 

From what I have learned so far, it boils down to this: When the device is plugged into the RT controller the Linux OS loads a driver module "usbhid". This supersedes or block MAX from also recognizing and claiming the device and any LV code that try to find the resource (through VISA functions) will also fail.

 

When first plugged in, executing "lsmod" from a terminal show the "usbhid" modle.

 

This can be "removed" (not entirely sure what that means in the Linux context) by typing "rmmod usbhid".

 

Now the shows up in MAX and works as expected. BUT, this is only temporary Smiley Mad!! Any un-plug re-plug or power cycle puts me back to square 1.

 

I have played around with looking for the "blacklist" file as well as running a command line through the System Exec function within my LV code at run-time. Thus far no luck. I cannot find the blacklist on the OS and I cannot get my permissions upgraded to run the rmmod command from LV (I have tried things like installing sudo and upgrading lvuser but either it doesn't work that way or I did it wrong).

 

I assume all of the above could be considered in a more generic sense (not specific to usbhid).

 

Any suggestions welcome!

0 Kudos
Message 1 of 3
(460 Views)
Solution
Accepted by topic author Jolt
05-18-2018 05:05 PM

Hi Jolt,

 

 

It looks like this is being actively troubleshooted in the other thread you linked, Re: VISA USB-RAW on cRIO-9030. If you do have any specific questions not answered there, feel free to make a new post.

 

Thanks,

Timothy D.
Applications Engineering
National Instruments
0 Kudos
Message 2 of 3
(411 Views)

Thanks, this was solved in the other thread.

0 Kudos
Message 3 of 3
(384 Views)