PXI

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

NI PXIe-8100 connectivity issue - NI Variable Engine: Error

I am trying to connect to my NI PXIe-8100 as a means of communicating with my NI PXIe-6361 for use as a real-time target. Both are installed in a NI PXIe-1071 chassis. The NI PXIe-1071 chassis is recognized by the MAX explorer, but the card of interest (NI PXIe-6361) is not.

 

Upon connecting the NI PXIe-8100 to a monitor and resetting the device (by pressing the "reset" button on the front panel), I get an error message "NI Variable Enginer: Error: Unable to load the MXS configuration plugin. Failed to get MAX configuration interface for Tagger" (see IMAG1438.jpg). At this point, the system gets stuck "flushing disk cache" indefinitely. If I turn off and reboot the PXIe-8100 device, it goes straight into safe mode upon recognizing that there's a softwre error, and calls for a system reboot (see IMAG1440.jpg).

 

I initially tried resetting the MAX Database, and also cleared the CMOS contents on the PXIe-8100. I then removed all National Instruments software installed on my computer and reinstalled everything. I am still getting the same error on the PXIe-8100.

 

 

I apologize if this is a somewhat naive or vague question; I am very new to these PXIe devices (and data acquisition in general). Any help would be greatly appreciated, as I am totally unsure of how to proceed.

0 Kudos
Message 1 of 3
(1,484 Views)

Hi,

 

I am an applications engineer working for NI Germany.

 

If the system is not booting in Safe Mode that hints to a corrupted filesystem. You can try reinstalling the RT OS on the PXI controller.

 

There is information about reinstalling your RT-PXI in this article: http://digital.ni.com/public.nsf/allkb/C121B7EB066F078D86256D6A0062E317

 

If your controller has a recovery partition you can try pressing F4 while booting, this will start a recovery utility. If your controller does not have this option you will need to connect a USB CD (or DVD) drive and use the recovery disk which was shipped with your PXI system.

 

If the issue is not fixed by reinstalling the operating system I would suggest you contact your local NI branch because it is likely a hardware defect. When did you buy the controller?

Applications Engineering Intern, NI Germany
Certified LabVIEW Developer
0 Kudos
Message 2 of 3
(1,452 Views)

Thank you very much for your reply - I think I've solved the issue. I was missing a few drivers it seems, and after totalling wiping the PXIe-8100 (and my desktop computer) and reinstalling the relevant software, it seemed to fix the issue. Further research seems to indicate that this is a system error that can result from shutting down the PXIe-1071 chassis without first exiting any tasks loaded onto the installed measurement cards..... Seems like a bit of a strange/unlikely error, so perhaps this is incorrect. Nonetheless, everything's work perfectly now. Thank you again!

0 Kudos
Message 3 of 3
(1,436 Views)