NI VeriStand Add-Ons Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

VeriStand FPGA XML Builder Node Feedback

Hello everyone, 

 

I am trying to use the FPGA XML Builder Node. I am experiencing a problem that someone already mentioned previously in this discussion. 

After the installation, when I try to put the node on the block diagram, LV automatically looks for some .dll files that are missing. I cannot proceed. 

Some of you solved this issue simply by copying the config file in the same folder of the labview.exe (as stated in the instructions) but i already did this step and it was not successful. 

Maybe the problem is that I have LV2020, but among the downloadable zips ( https://forums.ni.com/t5/NI-VeriStand-Add-Ons-Documents/NI-VeriStand-Add-On-FPGA-XML-Builder-Node/ta... ) the 2020 config file is not present, so I am trying with the 2019 version. 

 

If I am correct, could someone please send me the correct 2020 version of the config file? Any help would be appreciated. 

 

Thank you, 

 

Marco S.

0 Kudos
Message 171 of 174
(2,144 Views)

Hi Marco,

 

Maybe you can try editing the config file yourself, it seems that all it does is redirect from an old version to a new version...

 

<bindingRedirect oldVersion="2013.1.0.0" newVersion="7.0.0.0" />

 

In this case, "7.0.0.0" is for LabVIEW 2019. Try changing to your LV version and see what happens... 🙂

 

PJ

Message 172 of 174
(2,126 Views)

Hello Pianne, 

 

Thank you very much, it worked. Cheers!

0 Kudos
Message 173 of 174
(2,116 Views)

Dear all,

 

 I'm absolutely new to VeriStand..

I'm using the "VeriStand FPGA XML Builder Node" in order to:

  • read AI values from an NI 9215
  • write AO values to NI 9263

I had no problem in reading the AI voltages from NI 9215, but I can't update the AO voltages...

I've written this code for the FPGA:

 

Screenshot 2021-02-02 151448.png

 

(in order to test the "VeriStand FPGA XML Builder Node" I also added the possibility to switch on/off the FPGA LED).

 

I've generated the XML file, compiled the FPGA and imported both files in VS 2018.

I had no problem with the VS import:

 

Screenshot 2021-02-02 151826.png

 

When I try to update the AO (Mod4/AO0) or the FPGA-LED nothing happen.

Voltage is 0 and the FPGA-LED is OFF.

 

If I connect a constant to the FPGA-LED (constant=1) the LED turn on when I run the VS project, so the LED works.

 

Thank you for your help.

Paolo.

0 Kudos
Message 174 of 174
(2,027 Views)