NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Unable to load specified version of python



Tested with:

  • TestStand 2020 (32 bit) and TestStand 2019 (32 bit)
  • Python 3.6.11, 3.8.7, 3.9.1 (all 32 bit)

on Windows 10


when trying to use a Python Action I always get an "Unable to load specified version of python".

That happens with custom Python scripts as well as with the included examples.










In each case I selected the specific Version under Configure > Adapters ... > Python.

I also made sure the right version was specified in PATH. I tested that with cmd > python --version.


Workaround at the moment:

Use an "Call Executable"-Step and call python with the script name and variables as arguments.

That works well for simple scripts but should not be necessary and fails on more complex tasks.


Any idea what I'm doing wrong?





0 Kudos
Message 1 of 10



It is possible that you didn't provided a reference to the python properly.

Have you seen this article?

0 Kudos
Message 2 of 10

That is exactly what I did. With different versions and non of them worked so far...

0 Kudos
Message 3 of 10

Have you tried to reinstall TestStand?

0 Kudos
Message 4 of 10

since I had to setup a second machine anyways, yes I did there, with the same result.

0 Kudos
Message 5 of 10

Hi there

Is this issue is still relevant?

0 Kudos
Message 6 of 10

Yes and no...


Did not find a solution yet but as mentioned used a workaround. Not pretty but works for me for now. Can be closed I guess

0 Kudos
Message 7 of 10


I also was confused by this kind of error. Finally, I found out how to fix this issue, including LabVIEW. Some steps must be followed:

  1. Need to find the “niPythonHost.exe” on your pc(refer to the everything application);
  2. Copy the application to the LabVIEW and TestStand root directory;Carey_Cheng_1-1663741118234.png


  3. Done.

Of course, have to make sure that the same bitness and there is a path of python in the environment path.

0 Kudos
Message 8 of 10

Having the same issue, both TestStand 32-bit and Python 32-bit are installed and the PATH variable is correct.


The TestStand Adapter cannot find the Python Interpreter.  Every other Windows program can (i.e. CMD, VSCode, PyCharm, ...etc.).


This looks to be a common problem:


Is this a TestStand bug??

0 Kudos
Message 9 of 10

I noticed this knowledge article mentioned Python 2.7.0 or 3.6.0


"If you are using TestStand 32 bit version use Python 2.7.0 or 3.6.0, 32 bit version."


So I installed Python 3.6.8 and TestStand 32-bit was able to detect Python 3.6 32-bit.  Installing Python 3.6.8 worked.


This is not mentioned anywhere in the other knowledge articles. 🙄

0 Kudos
Message 10 of 10