NI TestStand

Showing results for 
Search instead for 
Did you mean: 

UUT name

Go to solution



I've been using the batch model.

I have 3 test sockets that run the same sequence.


I've been using the standard Window from Batch model to accept the entry of UUTs


I've found that the following property:



Contains the data entered in that window.


Everything was running fine for days on end.
However one of the days the technitian that was running the tests on the test rig came up to me saying that the software starts tossing errors at him stating that the property is not found.


I've checked and when I try to debug the sequence

the Logging component no longer appears .... 


When i run the same test sequence on my Laptop the issue doesn't appear.


Any hints why this might be happening would be appreciated.







0 Kudos
Message 1 of 5
Accepted by topic author Mac671

Do you perhaps have a customized process model? I do not think RunState.Main.Logging.UUT.SerialNumber is a location that normally exists.


I think with the default models you can get the serial number here:





Message 2 of 5

I have been using the batch model.

I've started with the BatchUUT.seq file and extended it, as far as I'm aware I'm using a standard Batch process model.

The variable has worked and  existed at that location but for some reason ins't availible to me anymore.


I found it by browsing though the watch window ... so I wasn't sure if I can "count" on the presence of the serial number under that address.


Thank you for your suggestion, I'm off-site today and won't be able to check the suggestion you've made directly on the test station but I'll do that Wednesday







0 Kudos
Message 3 of 5

well I managed to find


but there doesn't seem to be a




property where I can find the uut serial number input by the user.

I am using the parallel model.

Where can I find the UUT information?

0 Kudos
Message 4 of 5

Have you tried looking at that location while at a breakpoint in the execution document? It probably does not exist at edit time, but should exist at runtime.



0 Kudos
Message 5 of 5