Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

nimdnsresponder / error 100 / zeroconfservice in event viewer

I've been having a problem for a while and it seems to be fairly common, and I've tried all the fixes I've found on this forum and have updated to the latest system configuration and it's still happening.


My event log is filling up with errors like the one below.


The nizeroconfservice appears to be reaching out to everything on my company's network, from other PCs to printers and generating errors.


Can someone tell me what is going on and how I can fix it? I've cleared out my event log today and so far I've got 0.25M entries in the event log.....


The description for Event ID 100 from source niZeroconfService cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

No cache space: Delivering non-cached result for [Company Pc or printer here].local.

The specified resource type cannot be found in the image file


Here's another typical error:


GetCacheGroup: Failed to allocate memory for [CompanyPC number here]\032Web-based\032Configuration._http._tcp.local.


Can anyone advise?




0 Kudos
Message 1 of 5

Hi there,


So the NI mDNSResponder Service is used to advertise and discover ‘Zero Config devices and services’. It is often used by NI MAX to discover remote devices on the network, hence why it is reaching out to other devices such as printers and other PCs.

I can verify that I also get the same errors in my Windows Event Viewer, normally when starting the NI mDNSReponder service. This article explains a little more about mDNSResponder and Windows 7.


A CAR was filed to our R&D at the start of this year, however we couldn’t see the errors having any impact/consequence. Depending on your application, you could disable the service however you may encounter issues when trying to discover devices.


Is the error creating any unwanted/unusual behaviour other than filling up the Event Log?


Are you getting 0.25M entries of the error related to the ZeroConfigService?


Thanks Josh

0 Kudos
Message 2 of 5



Thanks for the response.


Regarding the entries, I was slightly wrong about the number. It was 0.25M new entries, i.e. lots and lots of entries every second, and these seem to be constanlty generated, so effectlively it's continually rolling and constantly filling up.


It seems to be affecting my PC performance, and another reason I want to sort it out is it makes trying to fault find other issues practically impossible.


It's something that shouldn't be happening.


For now I've killed the event log service, but I want it fixed.





0 Kudos
Message 3 of 5

Hi again,


That certainly seems excessive, do you currently require the mDNS Repsonder to discover any devices? Are you using any NI hardware? It would be interesting to stop the service and see if the errors still occur. As I mentioned previously, I am only able to reproduce the behaviour and errors when I start the service.


If you are using hardware, are you also running an application?


Let us know how you get on.





0 Kudos
Message 4 of 5

Coming up on two years with this post but I was experiencing the same behavior and wanted to comment on how I fixed it.


I simply had to stop the niLXIDiscovery and the NINetworkDiscovery services which the niMDNSResponder depends on.  I was then able to stop the niMDNSResponder and then I restarted them all.  I had to do this as an admin though so that might be an issue for some.  




Ben Johnson
0 Kudos
Message 5 of 5