Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

error 89130 with counters

I'm using a usb-6281 daq and keep getting error 89130 when I try to use the counter inputs.  The analog inputs and other digitral inputs work fine.  I'm testing it using Ni-Max.  I assume that if the analog inputs are working then it has nothing to do with resetting the device (which I've tried with no luck).  Any ideas?

0 Kudos
Message 1 of 3

So you restart pc, go to max, reset device, start test panel, counter I/O tab, edge counting from any PFI, it gives error, right? 

Try different USB, force uninstall/reinstall driver in windows task manager, different PC if possible, MAX Tools -> reset config data. If not, I would say it is bad, contact NI for repairs.

They will also need daqmx version (may ask to upgrade), and windows version. 

0 Kudos
Message 2 of 3

Tried restarting the PC (strictly a wall powered laptop) etc..  No luck.  Took the DAQ to another PC (laptop) and it worked fine.  Took another DAQ (a 6218), ran the same tasks from Ni-MAX after resassigning them to the new DAQ and didn't encounter the 89130 problem.  In other news, it appears the bug that I started with was a result of ground loops in the device I was given to measure.  I rewired the device and so far haven't encountered the intermittent signal.

0 Kudos
Message 3 of 3