Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

cDAQ-9189 can not see "reserve" when deployed

Solved!
Go to solution

I have installed a cDAQ-9189 chasis and when connected to LabView 2019 Pro I can make settings and run the Vi, all works as expected. Now I have to say this is the first time building an executable and installer. When trying to run the Vi on the deployed PC it loads up and tries to run, but no data from the cDAQ. Going into the deployed MAX I find that the chassis is reserved by another Host.

 

Following some instructions I found in this form or FAQ, error 201388. I see that I need to unreserved the chassis and then reserve it to the deployed host. But there is no "Reserve or Unreserved" button in the file drop down menu.

 

Reinstalled the development computer and was able to find the reserve and unreserved buttons. So, it is now unreserved. Repeated the build and installed. Still no drop down "reserve or unreserved" buttons in the drop down.

 

Any suggestions for a newboob?

 

Thanks

Paul

0 Kudos
Message 1 of 11
(1,646 Views)

Are you sure you included everything in your installer that you need?  If you just run your installer you should be able to go into MAX and reserve the chassis on the target machine.  Also are you unreserving and/or power cycling the chassis before you try it on the target machine after reserving it on the development machine?  Do you have any error handling in your exe to know the exact errors?

 

Once you can control the chassis in Max look at the DAQmx Reserve Network Device.vi and DAQmx Unreserve Network Device.vi.

 

_Bryan_0-1585595750355.png

 

Message 2 of 11
(1,589 Views)

Hi Bryan,

 

No I was not sure about including everything needed in the build or the installer. And as it turned out I had not included everything needed. I am a newboob to this version of LabVIEW and we used to have an engineer who built our executables in the past. About the 12th revision of the build and installer I found the right combo of selections that created a workable executable.

 

Now I am trying to install another executable to same host that have a shared ini file, a key file to be sure.

 

BTW I am thinking I might have to install that DAQmx reserve and unreserve Vis to my 2 Vis so that they both can take control (Reserve) when they launch.

 

Thanks for your input.

 

Paul

0 Kudos
Message 3 of 11
(1,581 Views)

Hi again Bryan,

 

Well I ended up adding the DAQmx Reserve and a Unreserve  to both Vis. I believe it has taken me one more step closer to getting this to work. I am still having some troubles with the second installed Executable.

 

Thanks

Paul

0 Kudos
Message 4 of 11
(1,569 Views)

Hey Paul,

If you are looking for more help on getting your programs running you need to be a more specific than "I am having trouble".  Could you help someone who only told you that they were having trouble when you do not know how what the program is supposed to do or what they are having trouble with?

 

You might want to make a new thread on what you are having trouble since this thread is marked as complete.

 

Bryan

0 Kudos
Message 5 of 11
(1,541 Views)

uh, hi Bryan,

 

Um, I found part of the problem, the part that got it so I can "Reserve" MAX and "Un-reserve it to. It was some of the setting in the build or installer that did it. But because I will be trying to run two different Vis on the same host and same cDAQ module. I added the DAQmx "Reserve" and "Un-reserve" Vis to the Main Vi and Calibration Vi. But something still wrong with the ability of the second Vi, the Calibration Vi.

 

I really don't know where you are coming from. I thought I was informative. My first post in this thread was not one of those "Help, my Vi does not work". It might have had some more info, but at the time I thought I covered fairly well. You did ask me if I had all of the boxes checked that I needed checked in the builder and installer. And truthfully I didn't know for sure..

 

Hey your answer was not a direct hit, but it got me thinking on a different angle and might very well have headed me in the right direction. Gave you a Kudo for your help. As you can see, this issue is solved and closed. Why the sour grapes in your last post?

 

Regards

Paul

0 Kudos
Message 6 of 11
(1,535 Views)

Wow,

No sour grapes here and thank for the kudo!

 

I was commenting on part of your last post:


@PaulVog wrote:

I am still having some troubles with the second installed Executable.


From that statement how would I know if it is the same problem or a new problem?  Anybody would need more information to help with the trouble you are having.  Posting in a new thread that is not marked solved would get more views and more help than having it in a solved thread.  And even though the thread was solved that statement sounds like you needed additional help.

 


@PaulVog wrote:

But because I will be trying to run two different Vis on the same host and same cDAQ module. I added the DAQmx "Reserve" and "Un-reserve" Vis to the Main Vi and Calibration Vi. But something still wrong with the ability of the second Vi, the Calibration Vi.


Can you see how the above information is more valuable and detailed than "I am still having trouble"?  I understand that you are a new user, we all were at some point.  But if someone asks for more information about your trouble, it is probably because it was not as fully explained as you thought.  Not sour grapes. 

 

But even the above information is still lacking important details.  Without posting your code (VI's not .EXE) it is difficult to know exactly what you are doing.  Are you trying to run both executables at the same time?  Or are you only running 1 program at a time?  Because you can only access the chassis with one program at a time.

 

So this is not sour grapes, I am trying to help you ask more specific questions to get the help you need.

See the link below:

https://forums.ni.com/t5/Community-Documents/Unofficial-Forum-Rules-and-Guidelines/ta-p/3536495 

 

 

Bryan

 

0 Kudos
Message 7 of 11
(1,530 Views)

Hi Bryan,

 

I had started a new post about the "Still having problems with the second Vi". Sorry that was really not a question just me musing about it. But I can see how you took it as a question. And under those circumstances I can understand were you were coming from. I didn't even think of that, I was on the first post. Different angles at looking at this thread. Hope I never become guilty of actually throwing out a question that sounds like my musing. I hate people who cry that they are hurt but don't offer up WHAT hurts.

 

BTW I am a maintenance man in a factory. Get lots of those "It wont work" So I do understand were you were coming from. Offer up my hand in a virtual handshake. 

 

Paul

0 Kudos
Message 8 of 11
(1,527 Views)

Oh, BTW I call myself newboob. But I worked and played with 7.1 and just a little bit with 8.5. Another of my problems is something  I used to know how to do, but a part of that slips me now days. I made a little part of my VI to have a password protection. Only one guy and me will know the password. I used a "one button" message to ask for the password. But when you type it in, it displays in the box. And I cant find how to change the display of the password to radio button (large dots).

 

So, I am slowly coming up to speed. We will do the calibrations by hand for now. At least the main program is working just fine as an executable.

 

Thanks again for pointing me in the right direction earlier.

Paul

0 Kudos
Message 9 of 11
(1,525 Views)

No worries Paul.

 

I had not check the forum for other posts, so I was just replying to this one.  I am just glad my initial response helped.

 

Bryan

0 Kudos
Message 10 of 11
(1,524 Views)