Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

USB-6001 Hardware Issue

I'm using a set of two USB-6001 DAQs to perform many functions such as measuring analog voltage, output digital signals, etc. This is implemented through a Visual Studio deployed program. When I attempt to run the program, I receive this error:

 

NI-DAQmx is unable to communicate with the device. Make sure the device is present in and accessible to the system, and is not currently being reset.

Task Name: _unnamedTask<E>

Status Code: -200324

 

This error also spawns a couple other errors:

 

Exception: Internal Software Error occurred in MIO software. Please contact National Instruments Support.

Task Name: _unnamedTask<12>

Status Code: -224606

Exception: No transfer is in progress because the transfer was aborted by the client. The operation could not be completed as specified.

Task Name: _unnamedTask<12>

Status Code: -50405

Exception: The specified operation cannot be performed because a task has been aborted or a device has been removed from the system. Handle this situation as required by the application and then, if appropriate, attempt to perform the operation again.

Task Name: _unnamedTask<12>

Status Code: -88709

 

I have ran this deployed program on two laptops: the development laptop and the tester laptop. When I connect both DAQs individually into USB ports, the program runs smoothly with no exceptions on both laptops.

 

When I connect the two DAQs to a self-powered USB 3.0 hub on the development laptop, the program runs smoothly.

When I connect the two DAQs to a self-powered USB 3.0 hub on the tester laptop, the above error occurs.

 

I understand that connecting the DAQs through USB hubs are frowned upon, but why is it that the DAQs operate on the development laptop and not the tester laptop? 

 

Previous projects have utilized the USB-6001 devices through USB hubs with minor issues. What are some steps I can take to resolve this problem?

 

Thanks for any help you may be able to provide.

 

 

0 Kudos
Message 1 of 5
(448 Views)

Just to be sure - either through Hub or direct, the Alias in NI MAX for the two 6001 is correct?

 

Just my speculation, if those USB hubs are generic Chinese versions and the drivers are not good enough, they might malfunction sometimes and may miss something at the USB protocol level which the DAQmx driver relies on for communication with 6001.

 

As a matter of fact, even the USB ports on Desktop or Laptop are through USB controllers which are a form of USB hub themselves, just that they are reliable.

 

Try with a branded reliable USB hub if possible and why a USB3.0 hub? maybe even try with a USB2.0 hub to see if any of the USB3.0 implementations are causing the issue.

 

To answer, how it functions on development but not on deployment, we need a complete comparison on what are the differences between them in terms of HW and SW installed to even make a guess.

Santhosh
Soliton Technologies

New to the forum? Please read community guidelines and how to ask smart questions
0 Kudos
Message 2 of 5
(437 Views)

I've gone through several different reliable branded USB hubs but unfortunately they produce the same problem. I actually tried a USB 2.0 hub recently just to see if it would make any difference as well.

 

I also apologize if I was unclear. Both laptops are running the deployed version, but the USB hub only works on one of the laptops (the laptop that the program was developed on).

 

I'm not sure if this is the error as it works on one laptop, but I would also like to add that the DAQ only malfunctions when it's reading an analog input. All other functionality of the DAQ appears to be functional.

0 Kudos
Message 3 of 5
(387 Views)

I've swapped out several USB hubs (both 2.0 and 3.0), but unfortunately they all appear to produce the same error.

 

I apologize if I was unclear, but the deployed version was ran on both laptops. It only threw the exception on the tester laptop.

 

I also am unsure if this is the issue as the program appears to be functional on one laptop, but the issue only occurs when I'm trying to read an analog input from the DAQ. All other functionality such as digital out and analog out appear to be working.

0 Kudos
Message 4 of 5
(429 Views)

Question - are those DO and AO implementations are software timed? and AI implementation is hardware-timed with sample clock?

 

If yes, then definitely something at the USB protocol level required by DAQmx for HW timed operations is messed up by the USB hub.

Santhosh
Soliton Technologies

New to the forum? Please read community guidelines and how to ask smart questions
0 Kudos
Message 5 of 5
(421 Views)