Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

PCI boards 6509, 6513, 6723 not working in SUSE

I have an openSUSE 10.3 box on which I've installed the PCI-6509, 6513, 6221, and 6723 boards. The problem is that in any configuration I set these cards in (have tried 16 pci slots) lsdaq can only ever see the 6221 board. The linux kernel is 2.6.22.5.31, the KAL version is 1.7, and I'm using the daqmx base version 3.10. I imagine I'm simply overlooking a small detail, but I've been reading the knowledge base and these forums all day to no avail.

If I do an lspci I get 4 unkown NI boards.

Earlier I managed to get all the boards installed and recognized on a fresh XP install, so I can rule out board failure. Unfortunately running XP on this box would be least desirable, and I hope to avoid it if at all possible.

has anyone else encountered this problem, or can anyone offer some advice on how to remedy it?

thanks in advance.
0 Kudos
Message 1 of 5
(2,080 Views)
On closer inspection I see that the 6221 is the only board in the group that is compatible with 3.1B.

it looks like 8.0mx is the solution to this problem, but it doesn't look like it's compatible with openSUSE 10.3.

I notice there's a part in the 8.0mx readme about this, I'm currently exploring this route and will post my results on completion.


Message Edited by ISaw on 07-02-2008 12:58 PM
0 Kudos
Message 2 of 5
(2,078 Views)
followed readme directions for configuring kernel source, still ran into the same error message "source in /lib/module/<kernel> does not appear to be configured for <kernel> aborting install"
0 Kudos
Message 3 of 5
(2,074 Views)
tried steps posted by Shawn B found in another thread. Install looks like it was successful, but now none of the boards are recognized by lsdaq.

I'll try tomorrow after uninstalling everything NI related and starting fresh.
0 Kudos
Message 4 of 5
(2,070 Views)

Hi ISaw,

Unfortunately SUSE 10.3 is not fully supported with DAQmx 8.0. According to the following document, it may or may not work with your version of Linux distribution, but may work with an appropriate version of NI-KAL installed or other workarounds.

What Linux Distributions Do National Instruments Drivers and Software Support?

S_Hong
National Instruments
Applications Engineer
0 Kudos
Message 5 of 5
(2,016 Views)